The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Tasks/Projects dissapeared in 1.7 upgrade + archive Thread Tools Search this Thread Display Modes
Is it just me or did repeating tasks get archived or disappear? I have a "Single Items Due Today" single item actions list such as: Review meetings, zero-out inbox, etc. Now I can't find the repeated step anywhere. I'll have to resurrect previously completed task and make it repeating again.

I also have several incomplete projects that got sent to the archive as well during the upgrade from 1.6 to 1.7. Granted they don't have any pending actions (just the project name and a grouped action with no single actions), OF still considers it "Remaining" when filtered. I can drag/drop it from the Archive but I don't think it should have been archived since the project itself was never set to completed or dropped, which was the intention of having an Archive.

If I Archive, will those items disappear again? I don't trust it.

Last edited by ZeroFill; 2009-08-28 at 09:55 AM..
The archive gets all completed actions, along with their parent structures. The parent structures are also left behind in the main database, unless they are also complete. OF is smart enough not to keep recreating parents in the archive.

For example, suppose you have a long running project "Run Dairy Farm" with a repeating action "Milk the cows" under it. You've milked the cows every day for months. When you archive for the first time a "Run Diary Farm" project will be created in the archive and all completed "Milk the cows" actions (completed before the archive cut-off date) will be moved to the archive under the new project. The "Run Dairy Farm" project will remain in your main database also, along with the incomplete "Milk the Cows" action (and all "Milk the Cows" actions completed after the archive cut-off date).

Suppose another month passes and you archive again. The completed "Milk the Cows" actions from before the cut-off date will now be moved to the archive under the existing "Run Dairy Farm" project. If you someday complete the dairy farm project, then upon archiving it the archive version of the project will contain all the completed actions and nothing will remain in the main database.

Upon upgrading to 1.7 you should have been prompted whether or not you wanted to archive.

I've been using the archive for nearly a year, since it was first added, and haven't lost any data. Rather than the incremental archiving OF currently uses, there are some folks who prefer to be able to view all completed actions for a project, and only archive the project when the project itself is completed. There's a thread on the forums discussing how to do that. (Sorry, I don't have a link. Try a search on "archive", or perhaps one of the participants from that thread will jump in here.)

Thanks for the reply. Unfortunately it didn't work out so well for me as I see a lot of my incomplete projects (with no tasks) in the archive. I guess OF must have at least one task in a project for it to keep it in the main database. In addition, my regularly repeating tasks disappeared too which will have to be re-created. Not too big of a deal, but it's going to be a hassle tracking it down or will have to revive a backup.
Thanks in advance for your help with this. I just bought OF for the iphone and was going to buy OF and start setting up syncing, etc. but this experience is giving me serious pause...

I'm an OF newbie, was learning the interface, watching tutorials, and setting up my system when the update system prompted me to update to 1.7.2 earlier today. Which I did. Since then it appears that I've lost everything (data/projects) except apparently the new contexts I added/modified...and all of my backups are listed as having the same timestamp since this update earlier today...I have four backup files all of which are timestamped "3:29pm" even the one I just did a minute ago.

I just upgraded to Snow Leopard, so I'm wondering if it's some strange intersection of issues or if there's a simple fix to this or if (gulp) the software isn't all that stable to begin with...

I've tried restoring from backup, but it's all gone from what I can tell, nothing in any of the earlier backups either.

Please advise.
@queenofspades - I think it's very unlikely you've lost any data here. Many of us have been using OF heavily for years now with no data loss whatsoever. In that respect, the app is extremely reliable. And I know the Omni Group considers data integrity to be of utmost importance.

I suspect the issue is related to your view bar settings. What do you see if you go to the Perspectives -> Show All Items view? Do you see your data then?

As for the timestamps on your backups, it's probably better to look at the time in the file's name rather than the modification time provided by the OS. Be aware, however, that the time in the name uses a UTC offset of 0 , I believe, so it likely does not match the time displayed in your menu bar.

@ZeroFill - Do you see your missing repeating task if you go to the Perspectives -> Show All Items view? OF does archive dropped and completed projects and tasks (including repetitions), but only after a period of inactivity. In other words, the item will only be archived if it is both completed/dropped and hasn't been modified in some number of days or weeks (not sure exactly how long that interval is).

I haven't lost any data but I do think there's some serious bugs with 1.7.2 and upward with Snow Leopard . I'd follow the instrucitions to verify your data is safe and then avoid using OF for now until omni finds out if the issue is with this build or it's a bug in snow leopard .
@Toadling: I don't see the missing single-action list items when changing the perspective in either the active or archive list. It has been sitting there incomplete for some time now (months?).

FWIW, the tasks I'm missing were in a single-action list "Single Items due Today" under a grouped action list "When Time"

I've given up and hoping this was a growing pains now that I've started to use Archiving. I'll report if it happens again. I've been using the app since the free beta period :)
I've tried looking in perspectives, projects, contexts and showing all projects and there's nothing there. Is there a way to check backups?
OK I just opened every backup in the directory from up to 5 days ago. None of them contain any of the information that was there, even the Omni Focus getting started project and actions are gone. Super frigging weird.

On a brighter note I just created an errand, backed up the file and quit, restored another (previous) backup and then restored this backup with the errand and it survived.

So I'm guessing the answer is to just rebuild it and hope it'll stay intact and backup like a mofo. Something happened in that upgrade process. That's all I know. Data lost but not contexts...I guess this should be added to the buglist for Snow Leopard. I emailed the support email as well about this.
Last ditch effort: I restored the file using time machine from before the installation...and it worked! The data is there, but courtesy of Apple Time Machine, not OF. Hmmm.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why don't some tasks archive when completed? [A: bug we haven't got a repro case for yet] MacDork OmniFocus 1 for Mac 4 2013-04-10 03:50 PM
repeating projects/tasks when all tasks/subtasks are complete? djc225 OmniFocus 1 for Mac 1 2012-03-20 06:55 PM
What happeneds when I archive completed projects... nineboots OmniFocus 1 for Mac 2 2009-01-21 05:35 AM
Q: Tasks (or projects) waiting on other tasks? budney Applying OmniFocus 10 2008-12-30 04:42 AM
Neat way to Archive projects and create Templates Macka OmniFocus 1 for Mac 1 2008-06-16 10:23 AM

All times are GMT -8. The time now is 09:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.