The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Sync Preferences Problem Thread Tools Search this Thread Display Modes
Quote:
Originally Posted by ksrhee View Post
Yes, it's working! Thanks for making this happen.
I spoke too soon. When I made a change in iCal and sync back to OF, I get this error now:

Unable to synchronize with iCal:

you referenced the following records (in a relationship) but did not actually push them: (
"61CC04EB-790E-46E6-9124-1F81DA7586A2"
)

The terminal command: defaults remove com.omnigroup.OmniFocus CachedCalendars made it work though.

Ken

Last edited by ksrhee; 2007-10-29 at 02:28 PM..
 
Hmmm. I ran that command, downloaded the latest build, and then tried to sync. No error message, just a pinging sound. Then no to-dos in iCal. I tried again, same thing. Then I go to the preferences and there are now three versions of each calendar in iCal on the left side of the sync prefs. Each time I try to sync, it adds a new set of calendars in the prefs.
 
I'm still getting this type of errors even though I updated it to the latest alpha.

Unable to synchronize with iCal:

you referenced the following records (in a relationship) but did not actually push them: (
"42FF73B1-ABE9-434E-AE6E-9E03BE90A1BA",
"FEECE33E-C39B-4E70-8237-BD49509F171E",
"DAA8AAC6-8BF2-4F09-9700-5D684C3E7AA8",
"96236CFB-E622-4C6E-B056-84C87E8BA4E7"
)

and the only way to get rid of this is to continue to run the terminal command (defaults remove com.omnigroup.OmniFocus CachedCalendars)
 
Am I doing something wrong? I've got OF syncing to iCal but when I add a todo in iCal and sync OF the new events don't show up until I click Clean Up. (I've tried synching with OF open and closed but the result is the same.)

Another issue is that when I create an event in iCal in the proper calendar (context) I'm using this format: "Call Bob [New Building Project] After syncing the project part disappears from ical until I sync again from OF.
 
it works! Not only does it work, but I'm really pleased with the new preferences functionality. In fact, with the new mail todo functionality I see a lot of tremendous functionality. It will, however, take a bit for me to figure this out in so far as how to coordinate this.
 
Quote:
Originally Posted by ksrhee View Post
I'm still getting this type of errors even though I updated it to the latest alpha.

Unable to synchronize with iCal:

you referenced the following records (in a relationship) but did not actually push them: (
"42FF73B1-ABE9-434E-AE6E-9E03BE90A1BA",
"FEECE33E-C39B-4E70-8237-BD49509F171E",
"DAA8AAC6-8BF2-4F09-9700-5D684C3E7AA8",
"96236CFB-E622-4C6E-B056-84C87E8BA4E7"
)

and the only way to get rid of this is to continue to run the terminal command (defaults remove com.omnigroup.OmniFocus CachedCalendars)
In build 93621, we've added a checkbox which logs some debugging information to the Console. Could you turn those logs on, quit, run the defaults remove command (to get back to a working state), then do whatever it takes to reproduce the problem (that would be useful to know, too) and send us a copy of the "Calendar sync" log messages from your console? You can get them by running the Console application (in Applications:Utilities), and send them to us by selecting "Send Feedback" from the Help menu and pasting them into your message there.

Thanks!
 
Quote:
Originally Posted by Ken Case View Post
In build 93621, we've added a checkbox which logs some debugging information to the Console. Could you turn those logs on, quit, run the defaults remove command (to get back to a working state), then do whatever it takes to reproduce the problem (that would be useful to know, too) and send us a copy of the "Calendar sync" log messages from your console? You can get them by running the Console application (in Applications:Utilities), and send them to us by selecting "Send Feedback" from the Help menu and pasting them into your message there.

Thanks!
I've been trying to replicate the error with the latest build, but so far no luck. I'm actually happy that I can't since it means I'm not having the same problem any more.
 
I finally got iCal syncing working by reseting sync data for iCal in the .mac system preference. Before doing that, strange things would happen on sync. Old to-dos would show up in the inbox without their contexts, nothing showed up in iCal. Anyway, after resetting sync data and doing all of the resetting mentioned in this thread, it seems to be working now.
 
All my problems went away after updating yesterday, this is absolutely fantastic. I can imagine it may be a bit unstable judging by the number of people who are having problems, but really... absolutely brilliant. It even worked with todo tasks I created in mail from an email I received. Cor blimey and all that.

I just felt I had to get this out seeing as my only comment so far was about this thing not working :P
 
Still seem to be having sync trouble myself. I have a few ical calendars, but only generic "calendar" listed in OF. Updates don't work yet either, but man! Even without iCal support for me yet, I think OF could be the one GTD progie that finally gets me organized. And that's awesome.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clip-O-Tron in OS 10.6.7 problem [Solved: Re-install via Preferences] PeterRHawkes OmniFocus 1 for Mac 6 2011-04-10 02:11 PM
Problem with Sync Preferences on 1.8SP Build Greg Jones OmniFocus 1 for Mac 5 2010-07-16 09:12 AM
Where is my sync preferences button? MichaelG OmniFocus for iPhone 2 2008-07-11 07:23 PM
Problem modifying Display Preferences Mark Millard OmniPlan General 2 2008-02-05 02:10 PM
Site preferences inspector problem jwa OmniWeb Bug Reports 0 2006-07-28 05:33 AM


All times are GMT -8. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.