The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus corrupting iphone Thread Tools Search this Thread Display Modes
I have been working with Apple techs because one of my apps was corrupting my iphone and causing me to have to restore frequently. It also was causing the iphone backup not to complete. It would get half way through and then stop. So, one at a time I installed my apps and then synced the phone. It turned out that it was omnifocus causing this. It was the only app that would not let the iphone backup finish. This would happen after I sync with my desktop version of omnifocus.

Since discovering this I did not re-install omnifocus and the phone has been fine. It appears that this only started happening since the latest release update of the omnifocus for iphone but I can't be sure that it was not happening before. I just know the iphone didn't start corupting till after the release.

Oh, also.....to make sure that the tests were accurate, I deleted all my apps from the phone and itunes and downloaded fresh clean versions to make sure I wasn't reinstalling corrupt versions.

Thanks
 
Interesting. How would any app you might install on your iPhone prevent iTunes from backing up the phone, I wonder...sounds like an iTunes bug to me (shock, horror, er, not)...
 
Quote:
Originally Posted by whpalmer4 View Post
Interesting. How would any app you might install on your iPhone prevent iTunes from backing up the phone, I wonder...sounds like an iTunes bug to me (shock, horror, er, not)...

As a developer myself I totally understand how this is possible. It corrupts that location in the firmware. I was also able to verify this with an apple tech.

Maybe you should stick with replying to threads you understand :rolleyes:
 
Sounds more likely that you have some bad flash memory or something hardware related. If OF was corrupting iPhones, I think more than a few people would have the problem and be talking about it here ;-)
 
Quote:
Originally Posted by enderwiggin View Post
As a developer myself I totally understand how this is possible. It corrupts that location in the firmware. I was also able to verify this with an apple tech.

Maybe you should stick with replying to threads you understand :rolleyes:
Thanks for pointing out the error of my ways. Here I thought all those years spent doing microcode, firmware, device drivers and operating systems work might have taught me something.

Maybe you could share some more of your wisdom and explain how the sandboxed OmniFocus app is corrupting "that location in the firmware" such that iTunes can't read the entire state of the device to do a backup?
 
enderwiggin: Could you please clarify a couple details? This is 1.0.2 of OmniFocus for iPhone, right? Which iPhone? Which version of the iPhone OS?

(As far as I know, we haven't had any other reports of this. If anyone else is experiencing this particular issue, we'd be very interested to know.)
 
Quote:
Originally Posted by Lizard View Post
enderwiggin: Could you please clarify a couple details? This is 1.0.2 of OmniFocus for iPhone, right? Which iPhone? Which version of the iPhone OS?

(As far as I know, we haven't had any other reports of this. If anyone else is experiencing this particular issue, we'd be very interested to know.)
Lizard,

I have an iPhone 3G and using the latest version of Omnifocus for iPhone. I have the desktop version of Omnifocus on my computer at home and at work. The one at home is using the latest alpha version and the one at work is one version behind the latest version.


whpalmer4:
Point taken on your experience. However, I still think it was rude and inappropriate of you to try to immediately try to disqualify me or my post without knowing anything about this situation. As far as I'm concerned if you don't didn't write this app or you're not an apple tech then there was no point for your sarcasm and you should keep it to yourself. I'm sure this forum would be better for it. As far as the technical side of your post..... This is the ONLY app out of over a dozen that would not allow the backup to continue. If it were a hardware or flash problem then it would do this with other apps as well. Also, from what I understand from the Apple techs the "sandboxing" is done to the entire 3rd party side. That's why if one app gets corrupted it CAN corrupt then entire installation and you have to restore with a fresh copy of the iPhone firmware. If you don't believe that call apple and debate with the techs there. One other thing, something you might want to keep in mind, someone who doesn't stop talking long enough to listen to others never learns anything. :cool:
 
Ender, I think you might have misinterpreted WH's first response - the post sounded to me like expressing surprise and curiosity about the problem, and suggesting iTunes as a likely suspect, and it really didn't seem rude or sarcastic or dismissive about you.

I'm not quite sure what you mean by the sandboxing being done "to the entire 3rd party side." Certainly the sandbox is not something that we are in any way responsible for or in control of, and each app gets its own sandbox (which is why we can't do things like have a separate inbox application).

I'm very sorry to hear about the problem (and curious about it) - that must have been very frustrating, the debugging effort you went through sounds quite tedious (speaking as someone who has don a bit of that to test how certain things work on initial install), and I'm glad that you have it resolved for the moment. But that leaves you without a working OmniFocus for iPhone, and I'm a bit baffled by the symptom - I can't see any way OmniFocus could be causing this problem, and I've not heard of anyone else reporting this problem.
 
@enderwiggin: You said, it happens after syncing with your mac. Is it possible, that your OF database is huge? Maybe the sandbox is getting backup into trouble if the application data is beyond whatever.
I know, that sounds pretty stupid... but as I am developer and qa guy too, I've seen a lot of stupid errors and made even more myself. It's just an idea, the problem sounds pretty strange to me.
Or did you give it a try with a different phone (to be sure, it's not a hardware specific problem)?
P.S.: If the apple guy knows, what he's talking about, there should be someone telling apple what all the sandboxing stuff is about. As far as I understood it (from the apple specs), it should be impossible for any application to corrupt others or the OS itself. For every application, it looks feels and works like the application is the only one on the phone or in the hole wide world.

Last edited by boris.baesler; 2008-08-12 at 11:29 PM..
 
Quote:
Originally Posted by Andrew View Post
Ender, I think you might have misinterpreted WH's first response - the post sounded to me like expressing surprise and curiosity about the problem, and suggesting iTunes as a likely suspect, and it really didn't seem rude or sarcastic or dismissive about you.

I'm not quite sure what you mean by the sandboxing being done "to the entire 3rd party side." Certainly the sandbox is not something that we are in any way responsible for or in control of, and each app gets its own sandbox (which is why we can't do things like have a separate inbox application).

I'm very sorry to hear about the problem (and curious about it) - that must have been very frustrating, the debugging effort you went through sounds quite tedious (speaking as someone who has don a bit of that to test how certain things work on initial install), and I'm glad that you have it resolved for the moment. But that leaves you without a working OmniFocus for iPhone, and I'm a bit baffled by the symptom - I can't see any way OmniFocus could be causing this problem, and I've not heard of anyone else reporting this problem.
It may be baffling but unfortunately i've had to switch to a different to do list program on my iphone. I purchased the omnifocus desktop version because it synced with the iphone version. A lot of money wasted for me.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Siri + OmniFocus [Siri support added in OmniFocus for iPhone v1.13] denrael OmniFocus for iPhone 89 2011-11-26 10:37 AM
iTunes Error 0xE8008001 when Trying to Sync Omnifocus iPhone App to iPhone 4 nbaker OmniFocus for iPhone 1 2011-04-08 02:26 PM
Due date grouping in Omnifocus vs Omnifocus for iPhone arnthorsnaer OmniFocus 1 for Mac 3 2011-03-16 12:53 PM
OmniFocus 1.6.3 for iPhone is now available Ken Case OmniFocus for iPhone 5 2010-04-28 01:42 PM
Search Function in iPhone App? [Yes; added in OmniFocus for iPhone 1.5] Mr. Reeee OmniFocus for iPhone 16 2009-06-22 09:47 AM


All times are GMT -8. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.