The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPad
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Sluggish Performance with iOS 4.2 Thread Tools Search this Thread Display Modes
Already sent this to the support ninjas, but thought I would post this here in case anyone else is experiencing this.

I upgraded to iOS 4.2 yesterday on my iPad and have noticed a significant drop in the performance of the OmniFocus for iPad app. Simply checking off an action as done can take several seconds for the checkmark to appear and then the item to disappear. Quite frustrating when I want to check off a bunch of items.

I have also noticed (and this was pre-iOS 4.2) that typing in the search is sluggish. I will bring up the search box and start typing and it will take several seconds for the first letter to appear. Once the first letter appears typing is smooth after that.
 
I personnally don't see any difference in performance. Since 4.2 introduced multitasking, is there a chance you may have another app running in the background that is hogging the cpu?

Just a thought, though it wouldn't explain your searching issue.
 
Quote:
Originally Posted by brt View Post
I personnally don't see any difference in performance. Since 4.2 introduced multitasking, is there a chance you may have another app running in the background that is hogging the cpu?

Just a thought, though it wouldn't explain your searching issue.
Nope, I've tried it after a hard-reset with OmniFocus the only app running and see the same issue.
 
Quote:
Originally Posted by patgallant View Post
I have also noticed (and this was pre-iOS 4.2) that typing in the search is sluggish. I will bring up the search box and start typing and it will take several seconds for the first letter to appear. Once the first letter appears typing is smooth after that.
This is because it is a dynamic match going on. When you type the first character, it has to find all of the entries in the database that contain that character, and compute and draw the display of the incremental results. When you type the second character, you've already narrowed the search space considerably, and by the third character it hardly has any work to do. I'm assuming we aren't talking about a pathological situation like searching for a string that appears in every single action, of course!

I suggested (via Send Feedback) that the search code might be modified to not actually start searching until at least 2 characters had been entered, or a suitable interval (maybe a second?) had passed since the last character was entered. If you experiment a bit with pasting strings into the search box, you'll probably see as I did that this is a much faster approach when you don't care about the initial incremental search results, and seems to do almost no harm when you do.
 
Quote:
Originally Posted by patgallant View Post
I upgraded to iOS 4.2 yesterday on my iPad and have noticed a significant drop in the performance of the OmniFocus for iPad app. Simply checking off an action as done can take several seconds for the checkmark to appear and then the item to disappear.
We talked about this in our OmniFocus meeting earlier today, and our current theory is that this is related to the recently-introduced feature to support local due notifications in iOS 4.2.

Does your performance improve if you turn off "Show Alerts" in Settings (under Sounds & Alerts)? If so, we'll focus our attention on making that code more responsive.

Thanks for your help!
 
Hi Ken,

After testing, I can definitely see a difference after switching "Show Alerts" off
 
Quote:
Originally Posted by Ken Case View Post
We talked about this in our OmniFocus meeting earlier today, and our current theory is that this is related to the recently-introduced feature to support local due notifications in iOS 4.2.

Does your performance improve if you turn off "Show Alerts" in Settings (under Sounds & Alerts)? If so, we'll focus our attention on making that code more responsive.

Thanks for your help!
Yes, that definitely helps speed things up. Thanks!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow performance? [A: We'll optimize performance later in the test program.] Xabier OmniFocus 2 for Mac (Private Test) 6 2013-04-12 05:46 AM
OmniGraffle 4 super sluggish Daniels OmniGraffle General 1 2010-03-03 10:44 AM
Omnifocus getting progressively more sluggish andrewebling OmniFocus 1 for Mac 4 2009-12-01 01:55 PM
Sluggish performance: launch alastair OmniFocus for iPhone 7 2008-07-15 07:13 PM
A bit sluggish? Zoolok OmniWeb General 49 2007-03-10 06:23 PM


All times are GMT -8. The time now is 02:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.