The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Temporary cookies not working ? Thread Tools Search this Thread Display Modes
Hi all,

Sorry for x-posting here and in OW general.

This simple script worked in 5.1.3 and works in a few other browsers I've just tested, but not in OW5.5:

page1.php
------------
<?php
setcookie('cookie_check','ok');
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<title>Cookie check:1</title>
</head>
<body>
If cookies are enabled cookie_check=ok has been set<br />
<a href="page2.php" target="_self">Proceed to page 2</a>
</body>
</html>


page2.php
-----------
<?php
$msg = "oops, can't get cookie_check";
if ($_COOKIE['cookie_check']=='ok') {
$msg = 'cookie_check is ok';
}
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<title>Cookie check:2</title>
</head>
<body>
<?php echo $msg; ?><br />
<a href="page1.php" target="_self">Back to page 1</a>
</body>
</html>


Thanks,
Ian
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Price dropped over the summer, then went back up? [A: temporary/promotional pricing ended.] avandelay OmniFocus 1 for Mac 8 2012-10-26 01:15 PM
amazon.com search box--temporary hang jjmccole OmniWeb Bug Reports 2 2007-11-18 02:42 PM
Broken handling of temporary cookies andybryant OmniWeb Bug Reports 6 2006-09-14 03:25 AM
Has anyone had problems with temporary cookies not being recognized in 5.5 ? ianm2 OmniWeb General 3 2006-09-13 05:08 PM
Bug (5.5b1): Google Maps - temporary text not removed from field earthsaver OmniWeb General 3 2006-07-20 04:19 PM


All times are GMT -8. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.