The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OW switching spaces Thread Tools Search this Thread Display Modes
Is it just me or does someone else have a problem with OW switching to another Space when you're typing a URL?
 
Sorry, can you be a bit clearer - do you mean that as you start to type an URL in the location bar of OmniWeb, you get switched to another Space, or is it something else?
 
I've run into some problems with Spaces too. At first I didn't realize that if you hold a window to the side of the screen it will switch spaces. The delay in that was a bit odd.

Spaces seems buggy to me, and I have problems in many apps so I don't think it's just OW.
 
Quote:
Originally Posted by JKT View Post
Sorry, can you be a bit clearer - do you mean that as you start to type an URL in the location bar of OmniWeb, you get switched to another Space, or is it something else?
Yep, this happens all the time. Only OW does this (and not only in the URL field but also otherwise) no other application that I can think of.

What happens is that I have a window open in Space 1, type 1-2 letters in the URL field and I'm switched to some other Space (I haven't discovered what determines where I get switched to).

Very irritating.
 
That I haven't experienced. My problem with OmniWeb and spaces is that it always brings either my Downloads window or my Network activity window to the front whenever I switch to OmniWeb, instead of the main browser window which was frontmost and active the last time I used it.

Sorry for the stupid question, but I have to check - you aren't pressing a control-arrow key combo to trigger this are you?
 
Quote:
Originally Posted by JKT View Post
That I haven't experienced. My problem with OmniWeb and spaces is that it always brings either my Downloads window or my Network activity window to the front whenever I switch to OmniWeb, instead of the main browser window which was frontmost and active the last time I used it.
I have a similar issue, but in just about every app. Switching spaces ends up showing a previously background window as the foremost window. InDesign, Photoshop, Acrobat... all do that.

The other issue I have that's more with OW in Spaces, is that although a new window may have been put in the foreground and it looks like it's in the foreground (eg, is darker atop) and the other windows appear to be in the background, hitting something like command+w will actually close the background window that was previously the foreground window.

Really irritating.
 
Quote:
Originally Posted by jem View Post
Yep, this happens all the time. Only OW does this (and not only in the URL field but also otherwise) no other application that I can think of.
I suspect that what happens is that the completion drop-down menu is actually a window which Spaces considers either (still) tied to the window that last shown a completion dropdown, or the Space that OW originally was launched in.

I don't know the technical details, but maybe OW could make sure that to the eyes of Spaces, the dropdown window "belongs" to the current window, so that no switch is taking place?

And yes, this is (by far) the currently most annoying problem for me in OW on Leopard, since I (like was mentioned in another thread) manage (browser-) windows per project into Spaces, not per application.

-Christian
 
Frustratingly, it appears this is not fixed in the latest 5.8SP.

Omni folks, I expect you already know this, but just in case... in OWCompletionController you're missing a call to:
Code:
[completionWindow setCollectionBehavior:NSWindowCollectionBehaviorMoveToActiveSpace]
And yes, this was so annoying I actually traced it down and verified the fix.
Please consider fixing this in a 5.8SP soon and I can remove my private hack :)

Axxel
 
Axxel: please send this on to omniweb@omnigroup.com so we make sure it gets properly handled.
 
I just hit my frustration threshold with this bug (no you're not the only one being hit by this ;-) and mailed support.

Then it occurred to me to search support, hence the forums for info on it.

Axxel - thanks so much for figuring out the fix.

Omni: can we please have a build that incorporates that?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spaces in Leopard albo OmniPlan General 3 2011-01-25 06:23 AM
1.8.1 broke Spaces? JakiChan OmniFocus 1 for Mac 4 2010-10-11 03:23 PM
OmniWeb & Spaces supertom OmniWeb General 2 2009-03-14 09:02 AM
Spaces support rzigweid OmniWeb Feature Requests 15 2008-03-09 09:57 AM
Workspaces and Spaces mjharper OmniWeb Feature Requests 0 2007-10-29 03:19 AM


All times are GMT -8. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.