The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Possible fix for large/slow syncs? Thread Tools Search this Thread Display Modes
I am SO bummed. Not because I spend $100 for the Mac and iPhone version, but because I can't keep this working in my configuration. I assume it is working for most other people.

When I started right after the iPhone version was released everything worked fine. I could sync between my MBP at work, my MB at home and my iPhone.

Sync with the laptops started taking a long time for the last few days. Syncs with my iPhone would NEVER complete the last couple days. Even over WiFi. I am syncing with Mobile Me.

I have upgraded to the latest version on my MB and on my iPhone this morning. I read the forums and checked the size of my db. 4.5 MB.

I archived a lot of items and then ran the script and it went down to 8KB. Now the syncs on the laptop are faster, but not quick. Maybe that is MobileMe being slow. It certainly isn't the file size.

But I still couldn't get a successful sync to my iPhone with the smaller file size. I finally reset the database, and started over on the iPhone. After a VERY long (5-10 minute) sync -- for 8KB -- I got the data onto my iPhone. But haven't been able to do an iPhone sync without timing out or the software crashing back to the iPhone home screen since then.

We are talking about 8KB here.

I looked in my MobileMe directory and there are dozens and dozens of cryptic zip files there.

I went into this fully understanding this was new and a "sneaky-peak". I purposely did not set up any repeating items or anything too complex. I do have some nested groups and more than 1 folder, but if I didn't have a lot of projects at work I wouldn't need syncing software to manage my to do lists.

I have updated all the software and compressed my db as suggested, but I still can't successfully sync to my phone, even after starting from scratch on the phone. I don't see any other quick fixes here on the boards. Should I try some other software and come back in a few months when this is stable?

If you ever get this working - it seems like an amazing product.

John :(
 
My db got very large and I was unable to sync from the iPhone, and MacBook syncs were pretty slow. I used other instructions and the script in the forum to shrink my db from MBs to KBs. But the syncs were still slow on the computer and still would not complete on iPhone. I have fixed it taking the following steps. These seem very risky, so do a regular back up first (File/Back Up Database...) and then use at your own risk. I was ready to completely give up on OmFo (and posted such in the forum) so I was willing to take a big chance.

Even after shrinking my database using the script, the problem seemed to be that there were still over 1000 .zip files in my MobileMe OmniFocus directory. I had tried resetting the database on my iPhone and starting from scratch using the smaller files on the server, but still could not sync without crashing or timing out. So I took the following steps.

1) In Finder, I created a new folder under iDisk/Documents which I called OmFoiD. (this was my OmniFocus iDisk temporary back up folder)

2) In OmFo on my MacBook, I went into Preferences and Sync and I switched the Sync location from MobileMe to iDisk. I followed the steps to sync to this new OmFoiD folder directly on my iDisk rather than MobileMe. This created a new/small/fresh set of sync content in that folder.

3) I used MobileMe on the web to go into my folders and navigated from the folder icon in the upper right to Documents to OmniFocus.ofocus. You may need to click or double click on the .ofocus folder once or twice to get the content to refresh. Then I selected the 1000+ files (I clicked on the top file, scrolled and shift-clicked on the last file) and deleted all the files. It asks for confirmation.

4) I then dragged and dropped the files from the OmFoiD back up folder in step 1 into the regular OmniFocus.ofocus folder. You have to have a clean set of these files to copy into the existing folder. If you just delete the content and try to resync it won't work. You probably could have done all of this from the web MobileMe interface, but you can not see the ofocus contents in Finder. This is the way I did it.

Now syncs on the laptop or iPhone literally take 5-10 seconds again, rather than a minute or more on the laptop and never completing on the iPhone.

It looks like every time I sync it creates another file on MobileMe and that as these files build up, sync speed might grind to a halt again . I like to save/sync often, because in my job, I am jumping back and forth between the Mac and the iPhone frequently as I go to meetings and get more items for my lists.

Looks like a manual/risky process to clean up until this gets built into the system. Seems like it should only save the last one or two sync backups.

Good luck. This brought back my iPhone syncing from impossible to fast. Use at your own risk.

JDF5
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Omnifocus Syncs with 2 of 3 devices...why? malbright OmniFocus Syncing 1 2013-05-09 04:00 PM
OG glacially slow w/ large numbers of elements jonkopp OmniGraffle General 0 2012-04-11 12:48 PM
OmniOutliner slow in opening large file dmdmd OmniOutliner for iPad 1 2012-02-08 10:28 AM
Coalesce more than two clients, solution to slow syncs JustinKent OmniFocus Syncing 3 2008-09-12 07:41 AM
Losing data during syncs. MichaelG OmniFocus Syncing 4 2008-07-13 08:55 PM


All times are GMT -8. The time now is 03:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.