The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Is anyone able to drag the forum logo to their desktop? Thread Tools Search this Thread Display Modes
sp4 - shift-dragging the Omni forum logo presents as though it is going to drag the image to the desktop, but drops as a .webloc file instead. I tried with a few other images and if they are links, they always appear as though you are dragging the image but when dropped are a .webloc file. If they are just images, they drag and appear on the desktop as images.

Anyone else observe this?
 
The problem is that it is an image file (gif) that is a link. If I control-click it and go to Image and download to the desktop, I get the image. I tried some other gifs (like the smilies at right in the compose window) that aren't links, and those work. But on another page where I have a gif that is a link, dragging yields a webloc.

Since you can get the image in a different way, I guess I'd consider this a feature rather than a bug. You probably want the web location more often that the image when you're dragging.

But, yes, I'm seeing the same behavior you are.
 
Even if it is the desired effect, I would still call it an UI bug because what you are presented as shift-dragging is the image, but what you get when you drop is its link. If you do a simple drag, you are presented with the target link as the thing you are dragging, not an image. I don't know what the equivalent behaviour was in OmniWeb 5.1.x (I'm fairly sure it was an image that was dropped when you shift dragged, regardless of whether it was a link or not), but if it is to drop a link to the image, it should display as such while being dragged and not as an image.

Thanks for reproducing this. I'll send feedback to OmniGroup.
 
I stand corrected. It works as you describe in OW5.1.3. A plain drag shows something that looks like a link (has the URL and favicon) and leaves the .webloc file. A shift-drag shows the image and leaves the gif file (after asking whether to replace the one I got from control-click and choose).

I hadn't thought about the visual feedback.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Panda bear behind OF 1.10 logo ? RobTrew OmniFocus 1 for Mac 1 2012-02-22 08:54 AM
Drag tab to desktop to create webloc Handycam OmniWeb Feature Requests 2 2006-05-26 01:50 PM


All times are GMT -8. The time now is 10:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.