The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
5.7 and memory management Thread Tools Search this Thread Display Modes
So, I'm still having issues with watching YouTube/Flash videos, but I have a Konfabulator widget that shows free memory which I use to monitor memory usage, and I've noticed something interesting.

During normal browsing, my Mac sits at about 2/3rds(in my case, round about 530MB ) free memory. Then OW crashes and I see that the free memory is down to about 1/3rd(usually down to 220MB ).

I can surf all day long sometimes, and it takes forever for the free memory to get that low. Or I can view some YouTube vids and the free memory drops like a rock. Also, if I leave OW to it's self, and go make dinner or something, and comeback, the memory has dropped way down, with no dynamic pages(other than Gmail ) in my tab set.

I can surf all day long with Safari, and never have that problem. Videos or not.

Any suggestions?

SC
 
Take a look at http://docs.info.apple.com/article.html?artnum=107918

Should you be worried if your computer only has 10 MB of "Free" memory? Probably not.
 
Thank you for the link Forrest, but my computer still crashes at 230 MB of free memory. And this only happens in OW and not Safari. Which is to not say that Safari won't continue to consume memory, but it won't crash/lock-up-the-system when the free memory reaches that level.

SC
 
Have you asked for feedback on the crash reports you've sent in? Often they'll tell you what it was related to. Then you'd know for sure if them memory issue is the problem.
 
Actually, they just sent me a reply to one of the many crash reports and saying it's a Flash problem, and not much that they can do for it.

SC
 
Quote:
Originally Posted by Smithcraft View Post
Actually, they just sent me a reply to one of the many crash reports and saying it's a Flash problem, and not much that they can do for it.

SC
Well, it seems to be at least one browser that doesn't have this life or death dependency lock in with Flash. Since it happens to be the one with very much the same code base as OmniWeb I have difficulties to believe this is the best explanation for the problem with the crashes. If I'm not missing something here, you are saying these crashes also appear without any Flash stuff loaded at all? If that's what you mean you could try the suggestion about asking for a comment, on a non Flash related crash report.
 
Quote:
Originally Posted by Smithcraft View Post
Actually, they just sent me a reply to one of the many crash reports and saying it's a Flash problem, and not much that they can do for it.

SC
I'm having some trouble locating your crash reports in the system - they don't appear to have been sent from the same email address used to subscribe to the forum - but I wouldn't assume that all the crashes are caused by the exact same thing. It may be just that particular crash that we responded to which was a flash problem.

If you send me a private message with the email address your reports came from, I can have a look. (Alternatively, you can post the ticket numbers in this thread, if you still have the auto-responses that get sent back.)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory Leaks? webswim OmniWeb General 9 2009-01-15 11:27 AM
Omni Memory Hog spalkot OmniWeb General 1 2007-10-20 03:19 PM
Workspaces and memory JulianAC OmniWeb General 4 2007-08-17 06:38 AM
memory leaks dustman OmniWeb Bug Reports 9 2007-03-23 07:12 PM
GMail CPU/Memory Hog? troutoil OmniWeb General 10 2006-11-28 11:23 AM


All times are GMT -8. The time now is 08:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.