The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Help - Can't Quit or Rebuild Database Thread Tools Search this Thread Display Modes
Help! Something I've done in this latest build 95919 has made it so that I can't quit or rebuild the database. I get the message "Unable to export while there are pending changes."

Is there something I can do? When I show contents of the .ofocus file, there are changes pending back to Dec. 5, which I'd hate to lose.

Also, I guess that means that updating the application does not do a rebuild, since I just updated this morning. I stupidly neglected to do a backup first. guess I got complacent because OF's been so stable.

Edit: I found a good backup to revert to. Never had to even look at the backup folder before this -- shows what a great experience this has been using OF. I believe this happened while I was creating, editing, and deleting projects in the sidebar while the (new) inspector was open. I'll try to recreate and send in a report if I can.

Last edited by eronel; 2007-12-12 at 06:35 AM.. Reason: add new info as indicated
I'm experiencing the same thing with build 95943 for quit or rebuild:
"Unable to export while there are pending changes."
Any suggestions for anything I might try to save all the changes I was just making?

I hadn't touched OF on my home machine for a number of days (using/updating it on work machine daily.) When I went to start it, I got a message about it having expired... I downloaded the latest version and went on my merry way, and all seemed well until I tried to quit and it wouldn't let me :)
If you make a trivial change to the document does that avoid the problem? Are you running an AppleScript that is turning off autosave? Any details on how to get into this state would be helpful. Thanks!
CTO, The Omni Group
Oh, I should also mention, that you might try closing all the window to get the main document to close -- it'll ask you whether you'd like to save in this case (whereas the quit path apparently doesn't).
CTO, The Omni Group
Whereas Quit and Rebuild gave that error message, I tried, "Backup Database" and that seemed to work without complaint. After doing that both Rebuild and Quit seem to work fine now. Thanks!
Good to hear -- if you determine how to get into that bad state again, please let us know so we can fix the problem for future generations.
CTO, The Omni Group
I deleted a bunch of my tasks, now I cannot quit, rebuild the DB or backup the DB.

Rebuilding DB generates this error:

CoreData could not fulfill a fault for '0x16275c50 <x-coredata://202A6539-5BAE-4525-9493-F75730EEB693/ProjectInfo/p8>'

I'm then locked in a loop where I cannot Cancel or Rebuild. The Rebuilding dialog box is stuck on the main page.
<content moved to new thread>

Last edited by benatan; 2007-12-13 at 01:47 PM.. Reason: promoted to new thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
"database on your iPhone is incompatible with the sync database" error message kevinwest66 OmniFocus Syncing 36 2011-05-08 04:32 PM
rebuild database not doing anything? jcg3 OmniFocus 1 for Mac 10 2009-03-22 06:58 AM
Coalesce or rebuild database? Jody Severson OmniFocus 1 for Mac 1 2008-09-04 07:22 PM
Tried to quit but got this BevvyB OmniFocus 1 for Mac 4 2008-08-23 06:42 AM

All times are GMT -8. The time now is 09:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.