The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniWeb redirects to page in Russian, Safari doesn't Thread Tools Search this Thread Display Modes
I came across very strange behavior from OmniWeb yesterday. When I try to connect to the link below using OmniWeb, my browser is redirected to a link in Russian. This does not happen with Safari. Any idea why this is happening and how to fix it?

Link: http://www.smartsync.com/

Omniweb redirects me to: http://www.smartsync.com/ru/
 
Just wanted to confirm and that it also happens with Opera but not with Firefox/Camino.

Workaround : in OmniWeb preferences > Languages > Request web pages in my preferred language(s) -> un-check it. Or do it for that page only.

Technically I have no clue right now but it obviously has something to do with default language smartsync request/OmniWeb returns.


o/
Thomas
 
Doesn't happen in my OW. You could try disabling JavaScript for that page only. I do have JS enabled, but have unchecked the two JS options in its sub menu for all sites.
 
If none of the above works, you may need to clear your cookies as well (in the security site preferences).
__________________
Troy Brandt
Omni Person
 
My OW defaulted to Portuguese while none of my other browsers did. I just closed OW and opened Opera to get the English site. I was messing with my system prefs and noticed that in International it had a very long list of languages. I only speak and understand English (sorry, I just never had an interest in languages) so I selected the Edit List button and unchecked all except English. My list only has English now and I just noticed today that OW now defaults to English sites.
 
I believe you can also download an English only version of OW.
 
Fwiw, if you don't want to disable other languages for the entire system, you can also do a Get info on the OmniWeb software (or other software) and deselect the languages it will make available for use. So you can do the reverse, if you wanted to run your app in e.g. Portuguese on an English language system.
 
I think he's referring to pages being served to him rather than seeing the OmniWeb interface loading in the wrong language.

To fix this, without changing any system settings you also could have turned off the "Request web pages in my preferred languages" setting found in the OmniWeb Languages preference panel.
__________________
Troy Brandt
Omni Person
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Omniweb vs Safari: H.264 playback webswim OmniWeb General 1 2010-03-10 05:02 AM
Launching OmniWeb brings up recent page, not designated Home Page jwthomas OmniWeb General 14 2008-05-29 10:55 PM
Launching OmniWeb brings up recent page, not designated Home Page jwthomas OmniWeb Bug Reports 0 2008-05-26 12:36 PM
page refuses to load OW Safari Drayon OmniWeb Bug Reports 0 2007-10-13 09:04 PM
WebArchive saved as a Safari page? otjacob OmniWeb General 2 2007-01-12 04:44 PM


All times are GMT -8. The time now is 07:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.