The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Unable to Lock Document Thread Tools Search this Thread Display Modes

For ages now I have been getting the following dialogue when OmniFocus is launched which I have it set to do at computer start up.
Unable to lock document.

This document was locked by My Name using the computer "my computer.local" on dd/mm/yyyy at hh:ss.

You may override this lock, but doing so may cause the other application to lose data if it is still running.
There are two buttons "Override Lock" and "Cancel". Needless to say I click on the former one and all is okay after that, until I restart the computer of course, then I have to do it again.

I have tried deleting this file:

~/Library/Application Support/OmniFocus/OmniFocus.ofocus.lock

as mentioned in this thread but this has made no difference.

I would be grateful if anyone has any ideas as to how this might be solved.

Thank you.
What kind of values are being shown for when the file was locked? 3 minutes ago, 3 days, 3 ages?

How are you exiting OmniFocus/shutting off your computer?

Thank you for your response. I have been monitoring things since your post.

I did some trials where I either shut down the computer with OmniFocus running or without it running however in those trials the "Unable to Lock Document" dialogue did not show up. So I could not give good answers to your questions.

Now out of the blue the dialogue has shown up again. I was not at startup of the computer (OmniFocus is in the startup items) instead it just came up after the Mac has been running already for hours.

The date/time very likely from the shut down before the last one. It is a bit over a day ago and I think I shut the computer down yesterday at the time stated, then started it up later again.
You didn't answer my question about *how* you are shutting down the computer. Shut Down... command under the apple menu, holding down the power button, yanking the plug out of the wall, what?

Probably you'll want to contact the Omni support folks via Help->Send Feedback in the app to get to the bottom of this. They'll probably want to establish that OmniFocus is getting an opportunity to exit gracefully (or determine why it isn't).
Originally Posted by whpalmer4 View Post
You didn't answer my question about *how* you are shutting down the computer.
Aha, I did not understand. I shut down 99% of the time using the command in the Apple Menu.

I will add that I am in the habit of quitting all applications first. I don't do it always but I do it quite a lot.

I use command-tab to bring up the app switcher and they go across using command-Q for each one. I don't know why I do this but frequently I do :)
Sounds like it should be a clean shutdown then. I wouldn't be surprised to see problems like you report if you were just mashing the power button until the machine shut off, for example. Interesting. Well, like I said, contact the support ninjas, they'll help you.
I just stumbled across a similar issue reported in our bug database. In that situation, the problem seemed to be related to switching network configurations. Are you joining and disconnecting from a corporate VPN or otherwise changing your network situation sometimes?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Unable to lock document. Another application had the OmniFocus document locked." drumshanbo OmniFocus 1 for Mac 7 2008-09-18 09:31 AM
SOLVED: Unable to lock document DannyG OmniFocus 1 for Mac 4 2008-07-29 05:31 AM
Error message : Unable to lock document. Anders OmniFocus 1 for Mac 3 2008-07-20 06:09 PM
Unable to lock document nestorph OmniFocus 1 for Mac 1 2008-01-07 04:24 PM
Unable to lock document? Betsy OmniFocus 1 for Mac 3 2007-10-01 12:53 PM

All times are GMT -8. The time now is 08:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.