The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Error message : Unable to lock document. Thread Tools Search this Thread Display Modes

When opening OmniFocus today I was greeted with a dialog-box saying :

"Unable to lock document.

Failed to write lock file. You do not have appropriate access privileges to save file “ .lock” in folder “Wombat HD”."

Looking in the /Applications/Utility/Console.App I find the message

"08 02 11 4:23:07 PM OmniFocus[82111] Presenting modal error: Error Domain=com.omnigroup.OmniFocus Code=2137 UserInfo=0x15839500 "Unable to lock document." {
NSLocalizedDescription = "Unable to lock document.";
NSLocalizedRecoverySuggestion = "Failed to write lock file. You do not have appropriate access privileges to save file \U201c .lock\U201d in folder \U201cWombat HD\U201d.";
NSUnderlyingError = Error Domain=NSCocoaErrorDomain Code=513 UserInfo=0x15835e00 "You do not have appropriate access privileges to save file “ .lock” in folder “Wombat HD”.";
"com.omnigroup.framework.OmniBase.ErrorDomain.File LineAndNumber" = "/Volumes/Disk/Users/Shared/bungi/ReleaseProduct/Source/OmniGroup/Applications/Focus/App/XML/LockFile.m:177";
} "

No other messages from OmniFocus can be found when searching in the

Any ideas how to get back to a running application? I tried to revert to a backup but I got the same message.

This .lock file is used to indicate that OmniFocus is using your file, so two different copies of OmniFocus don't try to edit it at the same time and confuse each other. So either OmniFocus somewhere else is using the file, or OmniFocus crashed the last time you used it and didn't get a chance to clean up after itself, or something like that.

1) Double-check that there isn't another copy of OmniFocus already running in your dock.
2) Go find and delete that lock file. It should be in the same folder as your database. By default this is in [user name]/Library/Application Support/OmniFocus, but you might have moved it somewhere else. From the error message, it sounds like it might be in "Wombat HD".
3) Now you should be able to open your database again.
4) If you do have your Focus database on a removable hard drive, always be sure to quit OmniFocus before you eject the hard drive.

If you continue to have this problem, I suggest you email our ninjas ( so they can help figure out what's causing it.
Thanks for the reply.

I was looking for the .lock-file in the location you specified but I had (unintentionally) moved the database to another location so I didn't find it. When a reboot didn't solve the problem I let it be. But the 10.5.2 update fixed it (or maybe it was the permission repair done before the update). Just moved the database back to the Application Support folder so that I will find it next time.

Whew! I had a lightning strike that messed up my computer and when it restarted I got this problem as well with the 1.1 sneakypeek. Deleting the .lock file worked. Thanks!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Lock Document Patrick J OmniFocus 1 for Mac 6 2013-01-08 04:40 PM
Error Message: Unable to read document, help please javimazzaf OmniFocus 1 for Mac 2 2012-10-19 01:40 PM
SOLVED: Unable to lock document DannyG OmniFocus 1 for Mac 4 2008-07-29 05:31 AM
Unable to lock document nestorph OmniFocus 1 for Mac 1 2008-01-07 04:24 PM
Unable to lock document? Betsy OmniFocus 1 for Mac 3 2007-10-01 12:53 PM

All times are GMT -8. The time now is 07:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.