The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iCal Sync
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Has anyone been using the iCal Sync functionality? Thread Tools Search this Thread Display Modes
Hi Ken (or anyone else), I am trying to sync to ical and my mac just gives me that negativesque little mac bleep we all know and kind of love(alert sound - Funk). Nothing happens except the 'Funk?!'. I was using sync in earlier alphas just fine but kind of forgot about iCal for a while. Would like to use it again if possible. Hope you can help me.

Norbu
 
You hear the alert sound that indicates synching is complete, but nothing actually shows up in iCal?
 
Quote:
Originally Posted by Kelsangnorbu
Hi Ken (or anyone else), I am trying to sync to ical and my mac just gives me that negativesque little mac bleep we all know and kind of love(alert sound - Funk).
Sorry for the lack of diagnostics; was anything logged to your console log? (You can view that log using the Console application in /Applications/Utilities.)
 
Hi Michelle. Q. You hear the alert sound that indicates synching is complete, but nothing actually shows up in iCal?

The sound suggests absolutely nothing will be done, like the program/system isn't even trying to carry out the sync. Its more like an instant *no! you can't!* kind of noise. Rather than syncing being complete and nothing showing, its seems as though syncing never starts and therefore nothing changes in iCal.

Hi Ken - there seems to be no change when I try to sync in the console log. I thought I'd include what it says when I start OmniFocus cos it's whinging about something it can't do:

===== Saturday, 2 June 2007 12:59:11 Europe/London =====
2007-06-02 13:00:10.707 OmniFocus[412] Can't open input server /Users/norbu/Library/InputManagers/Edit in WriteRoom
2007-06-02 13:00:10.897 OmniFocus[412] <TaskElapsedDateController: 0x11d8cf0>: Setting limit date of 2007-06-02 15:00:10 +0100 with predicate blockedByFutureStartDate == 1 AND effectiveDateToStart < CAST(202485610.895825, "NSDate")

Hope you can help.
 
I am stuck with having a calendar in our school's groupware system (FirstClass), which I then sync to my Palm (our groupware platform has conduits that work with Palm HotSync or MissingSync. I used to use the Palm HotSync, but now I use MissingSync).

The problem I have is it is my understanding that Sync Services only allows one "master calendar". So I can sync from my Palm to FirstClass calendar, but I couldn't then sync my Palm to iCal (which is syncing to OF).

Unless others know otherwise?

As an alternative I asked for a simple text export in this thread:
http://forums.omnigroup.com/showthread.php?t=3708
that I could at least read in the memos app on my Palm - it wouldn't be sync, but at least it would be some sort of reference I could have with me on my Palm.
 
Those who tried using Kinkless's iCal sync with a Palm remember that completing tasks on the Palm resulted in some odd behavior (usually that those tasks were not automatically marked as completed in Kinkless after syncing). The bug seemed to be in Apple's Sync Services and not in Kinkless so some slightly krufty workarounds were required to get it working.

My only question is this: Does OmniFocus sync correctly both ways consistently? I only wonder because the source of the bug really seemed to be in Apple's code and not Ethan's and fixing it in OF would require Omni to work around the bug in ways similar to what was tried in Kinkless. I'm just hoping that Omni found a way to get it working properly.
 
Quote:
Originally Posted by Kelsangnorbu
The sound suggests absolutely nothing will be done, like the program/system isn't even trying to carry out the sync. Its more like an instant *no! you can't!* kind of noise. Rather than syncing being complete and nothing showing, its seems as though syncing never starts and therefore nothing changes in iCal.
Yes, that sounds exactly like what's happening. (If for some reason we're unable to start a sync session, we play the system alert sound. We play a different sound when we synchronize successfully.)

Quote:
Originally Posted by Kelsangnorbu
Hi Ken - there seems to be no change when I try to sync in the console log.
It sounds like we need to add some more diagnostics to our synchronization process, then, so we can have some clue as to what's failing. If you haven't already reported this to our tech support ninjas by sending email to omnifocus@omnigroup.com, I highly recommend doing so now so they can start tracking this to make sure it gets resolved. (We do try to monitor the forums, obviously, but it's a lot easier to track email messages.)

Quote:
Originally Posted by Kelsangnorbu
I thought I'd include what it says when I start OmniFocus cos it's whinging about something it can't do:

===== Saturday, 2 June 2007 12:59:11 Europe/London =====
2007-06-02 13:00:10.707 OmniFocus[412] Can't open input server /Users/norbu/Library/InputManagers/Edit in WriteRoom
2007-06-02 13:00:10.897 OmniFocus[412] <TaskElapsedDateController: 0x11d8cf0>: Setting limit date of 2007-06-02 15:00:10 +0100 with predicate blockedByFutureStartDate == 1 AND effectiveDateToStart < CAST(202485610.895825, "NSDate")
This doesn't really have anything to do with iCal synchronization, but if you're curious:

The "Edit in WriteRoom" message is apparently caused by failing to load the WriteRoom input manager, but I don't know anything about that since I don't have that third-party input manager. (Maybe you had it installed, but then removed some part of it that it was using without removing this last piece from your InputManagers folder?)

The "Set limit date" log message is a debugging message in our start date scheduling code and doesn't indicate a problem (other than that we forgot to turn it off in non-debugging builds).
 
Quote:
Originally Posted by MEP
My only question is this: Does OmniFocus sync correctly both ways consistently? ... I'm just hoping that Omni found a way to get it working properly.
It should, and I'm not aware of any problems with completing a task and synchronizing that change back to OmniFocus. (That's certainly one of the most important changes we wanted to support, and in our testing this seems to be working well.)

If you notice any problems with this, of course, please let us know! The best way to do this is to send email to omnifocus@omnigroup.com by selecting "Send Feedback" from the Help menu. (Send Feedback will send information about your current build in the subject line, making it easier for us to know exactly which version you're using.)

Thank you!
 
I just thought I'd mention that we've added better error reporting to synchronization failures, so if you were having trouble with OmniFocus making an immediate *bonk* sound you might try again in a current build.
 
Which date is used for synchronization from Omnifocus into iCal - Start or Due ? I don't seem to be able to get things across with either date ...
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do To Do's need calendars to sync with iCal? [A: iCal requires they do so.] Othon Leon iCal Sync 2 2011-04-23 04:52 PM
iCal Sync - 1 Context -> 2 iCal Calendars visionsnap OmniFocus 1 for Mac 3 2010-01-16 08:00 PM
Moving to OF from Palm/Missing Sync/ical - can I import from ical? Don Richmond OmniFocus 1 for Mac 6 2009-09-03 07:00 AM
iCal sync and Leopard iCal Server? jstrat iCal Sync 2 2007-12-12 12:05 PM
Confused by iCal functionality snpower iCal Sync 2 2007-11-28 10:12 PM


All times are GMT -8. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.