The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Installed 1.1, got: "Could not create directory" Thread Tools Search this Thread Display Modes
I put in a ticket last night.

Was running 1.0.2, got 1.1, v77.4.0.102763, attempted to install, but after clicking the upgrade and backup button, got "Could not create directory". Rebooted, same deal. This morning tried v....768, same situation. Got stable 1.0.3 and that is working. Any clues about getting OF to be able to create the directory?


Last edited by omnibob; 2008-07-12 at 08:15 AM..
Check for error messages in Console? (It's in Applications/Utilities)
Great idea.

Following is from the console (I sent to the ninjas as well). Note that "tibob" is an old account. Not sure why it is being referenced. "bob" is my current account:

NSFilePath = "/Users/tibob/Library/Application Support/OmniFocus";
NSLocalizedDescription = "Could not create directory";
NSLocalizedFailureReason = "mkdir: /Users/tibob: Permission denied";


From: /Users/bob/Library/Application Support

drwxr-xr-x 5 bob staff 170 Jul 12 08:31 OmniFocus


7/11/08 10:10:09 PM OmniFocus[8527] Transaction "root=CA3941AB-EAAD-4A91-B9D6-40173EEADFE7:1E613AE1-14B3-437A-9E96-E31D7C359C04.xml" in document "file://localhost/Users/bob/Library/Application%20Support/OmniFocus/OmniFocus.ofocus/" appears to be from an older version.
7/11/08 10:10:09 PM[173] (0x100f40.VersionCueCS3monitor) Failed to check-in!
7/11/08 10:10:11 PM OmniFocus[8527] Upgrading document at /Users/bob/Library/Application Support/OmniFocus/OmniFocus.ofocus...
7/11/08 10:10:11 PM OmniFocus[8527] Presenting modal error: {
code = 13;
domain = NSPOSIXErrorDomain;
userInfo = {
NSFilePath = "/Users/tibob/Library/Application Support/OmniFocus";
NSLocalizedDescription = "Could not create directory";
NSLocalizedFailureReason = "mkdir: /Users/tibob: Permission denied";

Last edited by omnibob; 2008-07-12 at 09:27 AM..
Can you give us the exact text of the error message you're getting? That'll be helpful.

I may not be able to get back to you until tomorrow, but I'll take a look at this before Monday. (I have a friend's wedding to go to this afternoon.)
"Could not create directory"

1.0.3 prefs:

db loc: ~/Library/Application Support/OmniFocus/OmniFocus.ofocus

backup loc: ~/Documents/OmniFocus Backups

1.1 prefs:

There is no text showing at all about a db loc.

backup loc: ~/Documents/OmniFocus Backups

Contents of /Users/bob/Library/Application Support/OmniFocus:

drwxr-xr-x@ 9420 bob staff 320280 Jul 12 10:01 OmniFocus.ofocus
drwxr-xr-x 31 bob staff 1054 Jul 6 15:56 Perspectives

I looked back at my (manual) log of setting up my current computer, and I see that I migrated (copied over) the OF database and Perspectives file from the OmniFocus Application support folder (of my previous computer where "tibob" was my user name), but I am not finding anything related to OmniFocus at all in my current ~/Library folder, searching for "tibob", looking at "Contents", so I can't figure out where the installer is picking up reference to "tibob", as I wrote in this thread.


Last edited by omnibob; 2008-07-12 at 08:05 PM..
I'm getting the same error. From the console logs:

7/13/08 8:59:24 AM OmniFocus[89332] Presenting modal error: {
code = 20;
domain = NSPOSIXErrorDomain;
userInfo = {
NSFilePath = "/Volumes/joemuldoon/Backup/OmniFocus";
NSLocalizedDescription = "Could not create directory";
NSLocalizedFailureReason = "stat: /Volumes/joemuldoon/Backup/OmniFocus: Not a directory";

Note that "joemuldoon" is my username, not my login name (jmm).
My problem is solved. My hunch was/is that somehow, somewhere, sometime with my previous computer and different username, OF converted and stored ~/Library/Application Support/OmniFocus as the literal path, i.e., /Users/tibob/Library/Application Support/OmniFocus. So, running 1.0.3, I instructed OF to move the database to the Desktop, and after that, back again to it's default location. Then I upgraded to 1.1 v77.4.0.102775 just fine. I think that during the resetting of the db loc, that the old hard coded path got cleared, and the proper new location set (in terms of some internal OF reference). I'd still recommend the programmer(s) look to make sure this won't happen again if moving from one account to another (i.e., make sure the path isn't internally hard-coded).

Note that this time when the upgrade worked, I was using ...775, not ...768, the last build I tried. ...775 has a different dialog, asking if you want to Copy the db, which I chose, and a note about syncing. There is nothing in the build notes related to the problem I had, so I think my workaround is what fixed things, although I cannot be sure.

Joe's issue is at least partially different, but I would recommend trying my workaround.


Last edited by omnibob; 2008-07-13 at 08:26 AM..
Sorry about the poor error message! The underlying issue was that OmniFocus couldn't find or create the backup folder specified in General Preferences. We've fixed the error message to be clear about the actual issue, and we've also changed the upgrade code to recover by prompting for a new backup location rather than just failing.
I had been having the same problem with the creation of a directory, though I can't remember whether I had installed OF before I changed computers. In any case, I tried Bob's suggestion and it worked. Now I'm able to use OF 1.1 and synchronize with my iPhone. It seems to be working well. Thanks Bob!


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the location of "Omnifocus Backups" directory ScottNYC OmniFocus 1 for Mac 1 2012-03-30 11:29 PM
Can I default to "Embed attachment" rather than "Create link?" eepmatt OmniFocus 1 for Mac 4 2011-03-14 07:44 AM
How to create task with "due date" BUT without "due time" ? fire00 OmniFocus 1 for Mac 3 2010-04-14 12:36 AM

All times are GMT -8. The time now is 07:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.