The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Bug with flagged items Thread Tools Search this Thread Display Modes
Hi gang,

I just stumbled upon a bug in OmniFocus 1.7.5 when it comes to viewing flagged items.

Summary of the bug:
When ALL of your FLAGGED ACTIONS for a particular project are ALL MARKED AS COMPLETE, OmniFocus will no longer show you those flagged items in any view that is set to show you flagged items (regardless of completion status).

Details of the bug:
Here is how you can reproduce the bug yourself.

1. Choose "View>Planning Mode".
2. Choose "File>Add Project" to create a new project.
3. Create a bunch of actions for that project.
4. Flag 3 of those actions.
5. Choose "View>Show View Bar" to bring up the view bar.
6. On the view bar, choose the following settings:
Project Filter: All Projects
Grouping: Ungrouped
Sorting: Unsorted
Status Filter: Any Status
Estimated Time Filter: Any Duration
Flag Filter: Flagged
7. After you do that, OmniFocus will show you just your 3 flagged items for that project. This is normal and works as it is supposed to work! :)
8. Now, check the checkbox for 2 of those 3 flagged actions to designate those 2 actions as complete.
9. Refresh your view by clicking on a different project and then going back to this project again.
10. Again, everything is normal! It shows you all 3 of your flagged items, as it should! :)
11. But now, check the checkbox for the 3rd flagged action. Note that all 3 of your flagged actions are also marked as complete.
12. Refresh your view by clicking on a different project and then going back to this project again.
13. Uh-oh... this is where the bug crops up. Suddenly, OmniFocus shows you NO FLAGGED ITEMS AT ALL. The screen is BLANK. Even though you've told OmniFocus to show you flagged items (regardless of completion status), it is NOT showing you any of your flagged items. It is coming up BLANK, as if you have no flagged items at all.

Thanks,
Scott
 
Yep, looks like a bug! Use Help->Send Feedback to send in a copy to Omni.
 
Thanks, I just sent them an email! :)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reorder flagged items ? Linda OmniFocus for iPad 1 2012-07-29 12:49 PM
Set color of flagged items? dcernst OmniFocus 1 for Mac 1 2010-08-15 03:35 PM
Flagged Items Perspective tedroden OmniFocus 1 for Mac 3 2010-02-03 08:03 AM
Reorder Flagged Items gdevore OmniFocus 1 for Mac 2 2009-08-26 02:52 PM
Only Show Flagged Items? steve OmniFocus 1 for Mac 14 2007-10-12 08:12 AM


All times are GMT -8. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.