The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Pasting URLs no longer opens a tab Thread Tools Search this Thread Display Modes
I didn't see this mentioned in the release notes, but if you copy a URL, switch to OW 5.5sp1, and paste, it no longer opens that URL in a new tab. If you click the space inbetween 2 tabs and then paste, it does work, but normally you wouldn't need to to do that.
 
This doesn't sound any different from the behavior in 5.1.3 and earlier releases.

You need to have the focus on the tab drawer before you can paste in to it. Clicking empty space in the drawer gives it focus, or you can click a tab, wait a moment (to avoid a double-click, which opens the tab in a new window) and then click again to bring focus to the drawer.

Certainly if you can outline a scenario where the behavior is different than it was in older releases we'd like to know about it so we can fix it.
 
OK, I checked in 5.1.3 to make sure I wasn't being daft. Here are the steps to reproduce:

* Copy a URL from another app (I used Safari)
* Switch to Omniweb 5.1 by clicking the dock icon, or using cmd-tab
* Press paste before doing/clicking anything else, and the URL should open in a new tab.

In 5.5 sp1 & 3 this doesn't happen.
 
Yes, that's right: in OmniWeb 5.1, pasting a URL into a web page did open a new tab for that URL, and we seem to have lost that ability in 5.5 (no surprise, since it's now a WebView rather than an OWKHTMLView).

It looks like the problem is that the WebView is disabling the Paste menu item because it's not editable, which doesn't let Paste continue along the responder chain and find our controller which would, in fact, allow you to paste. I think we can probably fix this fairly easily by intercepting the menu item validation at the window level (before it reaches the view).
 
Quote:
Originally Posted by Jon Hicks
but if you copy a URL, switch to OW 5.5sp1, and paste, it no longer opens that URL in a new tab. If you click the space inbetween 2 tabs and then paste, it does work, but normally you wouldn't need to to do that.
This was never a problem for me, because I never worked this way. I learned to click inside the tab drawer and paste the URL so that OW could open it in a new tab.
 
Quote:
Originally Posted by eugene
I learned to click inside the tab drawer and paste the URL so that OW could open it in a new tab.
Sure - but you didn't have to click the tab drawer, that was the beauty of it!
 
Quote:
Originally Posted by Jon Hicks
Sure - but you didn't have to click the tab drawer, that was the beauty of it!
Switching to an app does not guarantee which part of the app has the focus. Should the URL automatically be loaded in the current window and current tab, automatically be loaded in the current window and new tab, automatically be loaded in a new window, or be pasted into the Location field without automatically loading anything?
 
I know what you mean, but as this is current OW behaviour, I think 5.5 should continue it.
 
I'm reviving this thread because this seems most appropriate to my comment.

Like Jon, I use the paste feature all the time. I love not having to open a new tab before pasting. In SP5, it seems that while I can select Edit -> Paste to get the desired behavior, using cmd-v doesn't give me that behavior, I only get the beep sound that comes from hitting a key with no action assigned.

Otherwise, holy fast browser batman! I wish I had some time right now to just play with it, instead of rushing out the door for another meeting.
 
Quote:
Originally Posted by eugene
Switching to an app does not guarantee which part of the app has the focus. Should the URL automatically be loaded in the current window and current tab, automatically be loaded in the current window and new tab, automatically be loaded in a new window, or be pasted into the Location field without automatically loading anything?
The way I have always looked at this feature (and just naively assumed it was intended that way) was that it behaved in the same manner as a link from an external application... When nothing has text focus and you paste a URL, thats essentially what you're doing, except manually bringing it from one application into OmniWeb. If you want it to go in the location bar to replace the current page, you should select that first so there is a proper focus.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening app opens new outline rogbar OmniOutliner 3 for Mac 25 2013-10-08 12:12 PM
Trouble pasting Chrome links/URLs [Known issue: see thread for workaround.] hawkettc OmniFocus 1 for Mac 15 2010-08-24 08:15 AM
RSS opens Safari- how can I use Omni instead? Woldharmony OmniWeb General 2 2009-04-30 03:37 PM
URLs ??? Boatguy OmniFocus 1 for Mac 1 2008-03-19 10:21 AM
downloads no longer get URLs in finder comments afb OmniWeb Bug Reports 2 2006-05-02 11:42 AM


All times are GMT -8. The time now is 07:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.