The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Why do I get two copies of omnifocus loading? Thread Tools Search this Thread Display Modes
Every so often omnifocus launches automatically and oddly two instances of the app appear in my dock. Quitting one kicks up an error about the database file being locked, and asking if it can 'Override' the lock.

What's going on? It gets quite annoying.

Thanks, Andrew
 
You have 2 versions of OmniFocus installed, and Launch Services is very easily confused :)

When the 2nd one launches, right-click its Dock icon and choose "Show in Finder", then you can see where it's hiding, and, if its not where you expect it, you can delete it.
 
Nope, only one copy installed. Both apps that appear in the dock point to the same location. What gives?
 
How many copies show up in a Spotlight search?
 
The next time you have two copies running, you might try running this command in a Terminal window to see where both copies are located:

Code:
ps axww | grep OmniFocus | grep -v grep
Let us know what you find!
 
Ok just happened again. Here's what the grep command says:

886 ?? S 0:01.79 /Applications/OmniFocus.app/Contents/MacOS/OmniFocus -psn_0_376924
887 ?? S 0:02.16 /Applications/OmniFocus.app/Contents/MacOS/OmniFocus -psn_0_381021

Any suggestions?

Thanks,

Andrew
Attached Thumbnails
Click image for larger version

Name:	Picture 1.jpg
Views:	323
Size:	15.6 KB
ID:	889  
 
Are you on an Intel-based mac, or a PowerPC mac? All of our applications ship as universal binaries; maybe the binaries for both chip architectures are getting launched?

Not that I have any idea why that would be happening...
 
Intel. I am clueless about why it is happening.
 
When you're getting the 2nd version... are you using Clippings/QuickEntry/Mail/Applescript?
 
I don't think so, but then again I am not quite sure what you mean. Here is my clippings preferences pane if that helps.
Attached Thumbnails
Click image for larger version

Name:	Picture 5.jpg
Views:	296
Size:	12.7 KB
ID:	890  
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating copies of tasks Philabeemer OmniFocus for iPad 2 2011-05-05 05:20 AM
Templates saving as copies? marcus OmniGraffle General 1 2010-08-25 05:24 AM
OF Bug? Launches itself - 2 copies? kidtreo OmniFocus 1 for Mac 1 2009-04-27 03:14 PM
Loading Omnifocus 1.5 when rebooting got.mac OmniFocus 1 for Mac 2 2008-11-19 12:19 PM
OmniFocus Loading Time on iPhone Evert OmniFocus for iPhone 60 2008-11-07 03:01 PM


All times are GMT -8. The time now is 01:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.