The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniFocus windows jump between Spaces Thread Tools Search this Thread Display Modes
Lately I've started using Spaces more actively, and this has been causing problems for OF. It seems that OF can't tolerate being in two spaces at the same time.

I typically have one workspace for a specific project and another one for more general stuff and planning. I'll have my main OF windows in the latter, but I'll usually want to keep an OF window with the project todo-list in the former. For some reason the OF windows will often jump to the other space whenever I do an action in them. It seems like they always jump back to the space OF was launched in. This is really annoying.

I haven't seen anyone else mentioning this problem. Is this happening only to me?

EDIT: Relaunching helped this time. Could the problem have been creating the spaces after OF was launched?

Last edited by Humbro; 2009-06-24 at 12:48 AM..
 
It has been my experience in general that anything create before spaces is kind of messed up with spaces.

So far OF is working ok in spaces for me.

However there are programs, MS Office 2008 for example that absolutely do not work well in spaces at all!
 
For me this seems to work OK sometimes, then suddenly I see the same broken behaviour you mention. Not sure what triggers it, but you're definitely not alone with your problem.

BTW, my spaces setup has been the same for about a year now, so it doesn't seem to matter if you created your OF database before activating spaces or not.
 
Reassuring that other people experience this problem :)

It's the same for me now: it usually works OK, but then OF windows suddenly start jumping between the spaces again. I guess we should send the omni people a bug report.
 
I'm seeing the same issue. I would move it to another spaces window than I launched it and everytime I tabbed to the next field, it would jump me back to the original spaces window I launched it in.

this is with Snow Leopard 10.6.2
 
I doubt it's a bug. There are some nuances to Spaces. They are strange, and I've ended up not using Spaces as I haven't been willing to spend the time to reconcile.

Fiddle with the "When switching to an application, switch to a space with open windows for the application" preference. There may be options to collect windows within Spaces.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus for Windows or Web [A: No plans for Windows app, Web possible someday.] benlavender Applying OmniFocus 22 2012-11-16 01:26 PM
OmniFocus for Windows Jean FABRE OmniFocus 1 for Mac 10 2012-06-11 02:22 PM
OmniFocus + Spaces - shortcut problem martinopia OmniFocus 1 for Mac 2 2011-06-01 07:34 AM
Trouble with Spaces and Multiple OmniFocus Windows thinkingserious OmniFocus 1 for Mac 7 2010-02-11 09:23 AM
Two OmniFocus windows. SonicSoul OmniFocus 1 for Mac 2 2007-12-01 02:23 PM


All times are GMT -8. The time now is 03:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.