The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Stumped by a heisenbug possibly related to OF Thread Tools Search this Thread Display Modes
I'm hoping maybe someone else has had a similar problem and may be able to point me in some useful direction.

I'm running a MacBook Air and and iPhone 3G, Snow Leopard, and using Time Machine for backups. I believe my OmniFocus for all devices is up to date. When I have OF up on my computer for a long-ish time (a few hours or more), the computer will start slowing down until eventually it grinds to a halt. When I pull up Activity Monitor to find out what's going on, it shows the "Kernel Task" using 150% or more (!) of the CPU capacity.

The Kernel Task overload seems to be a known problem, although I haven't discovered a known cause. When this happens I typically have a few other apps open (iCal, Mail, Safari), but closing them doesn't seem to help. Eventually everything gets so bogged down that I have to Force Quit every app and restart. One recent time it got so bad it corrupted my Time Machine drive and I lost all my old backups. Time Machine and/or syncing may also relate to the problem -- I'm not sure.

I don't know if OF has anything to do with this. All I know is that I started having the problem when I started using OF, and I've not had it, at least not this bad, except when OF is running.

If you have any ideas at all, I would be so grateful for direction on this. It's making me reluctant to open OF, and that in turn is really hurting my productivity.

Thanks for reading!
 
I would try creating a new user account on the same machine and see if the same thing happens. If it does, you might try a system reinstall, which might work, but I would guess that it is a hardware problem at that point. If it doesn’t, then you might try moving all the contents of the Library/Preferences and Library/Application Support into folders on the desktop (and trash the contents of Library/Caches) and see if that fixes it. This kind of sounds like a FileVault problem - you don’t have that running on your system do you? Another prime suspect would be dropbox - are you using that to sync?
 
I am using MobileMe to sync, and I guess that means I'm using iDisk. OF syncing is the only thing I'm using iDisk for, although I sync calendars and contacts with MobileMe. I've been wondering how that bears on the problem as well.
 
What happens, exactly, if I trash Library/Caches, and is moving the other two library files you referenced a necessary prerequisite for clearing out the caches folder? This is a little more technical than I'm used to. Thanks for your ideas and help!
 
The Preferences and Application Support folders, in your library folder, are used by your applications to keep information. This is information for use by the application, generally, not like your documents, which you probably save in your documents folder. The caches folder keeps information for quick access for applications.

Sometimes information kept in those folders can be written incorrectly and cause problems.

If you move them out of their normal folders, the applications will create new files. You may notice that your applications may not remember that you have a license (!) and may not remember your view settings, but if you move them back into place that should all be restored. Your caches folder the applications themselves can rebuild. But DONíT trash your preferences and application support - you may want to try putting some of them back later.

Keep in mind that trying to refresh your preferences is a good step only if it is likely that the problem is in your home folder, and not in your computer system as a whole. So I would check whether the problem still happens if you are working in a new user account first. If the problem still occurs, then moving your preferences probably will not fix it and would be a waste of time.

This does sound like a somewhat serious issue. Make sure that you have a good backup and consider the possibility that you may have to bring your computer to an expert.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
iCloud support? [A: Possibly in future, not at launch. See thread.] subotic OmniFocus Syncing 23 2012-08-15 07:51 PM
Possibly off topic: How do you do your iPad training videos Aaron OmniGraffle for iPad 1 2011-08-12 04:37 PM
Stumped- Move Magnet Position? rmogull OmniGraffle for iPad 8 2010-12-28 10:09 AM
I had an [input-related] dream... howiem OmniFocus for iPad 1 2010-08-01 05:35 AM


All times are GMT -8. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.