The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
'Replace your database and start syncing?' Thread Tools Search this Thread Display Modes
See attached picture for the message I'm getting.

I have been trying to solve this problem for so many months. I have rebuilt my database, unregistered and re-registered all the clients, backed up and started fresh with a DB, but every so often I still get this problem.

It used to only be on the computer side, but now it's only been on the iPhone side. I only have one mac and one iPhone set to sync via WebDAV on a SwissDisk. Any suggestions? I really want to rely on OF as a robust, leakproof system and this kind of problem that results in data loss is REALLY annoying.

Any other questions about my setup please ask, but I really want to solve this once and for all!
Attached Thumbnails
Click image for larger version

Name:	51765955-767057117ebe726a813d2b2d5944d6b0.4b3a09e8-full.jpg
Views:	351
Size:	39.6 KB
ID:	1215  
 
Sorry for the trouble this is causing! The first thing to do is make sure that you're running fully up-to-date copies of OmniFocus on all your devices. (Sometimes there's more than one copy of the app installed on a Mac, so you'll probably want to use Spotlight to locate any older copies that may still be on the machine. If you find any, move them to the trash.)

The current release of the Mac app is version 1.7.5, which you can grab from this link.

Next, check the very bottom of the Settings screen in OmniFocus for iPhone to make sure that you have version 1.5.3 installed. (Tap the toolbar button that looks like the letter "i" in a circle to bring it up.) If you have an earlier build of the app installed, the "Update" screen of the App Store app on your phone will help you grab the most recent release.

Previous versions of OmniFocus could start showing this error message if sync was turned off and then back on while the various devices weren't fully synced up. You'd end up with some transactions attached to the database in a way that didn't make sense, thus causing this message to appear. That's one possibility here. If there's an older version of OmniFocus in use, it could be attaching some transactions in a way that doesn't make sense; that would cause the other devices to start showing this message.

Another possibility here is if the "compact database" button or menu item was used on one device while the other one had un-synced changes. When that happenes the message is not an error. When the other copy of OmniFocus compacted the database, it meant that this copy was left with some transactions that it can't attach. If this sounds like what you're seeing, the solution would be to let OmniFocus compact the database on it's own schedule rather than manually trigger it.

Those are the two main possibilities I can think of off the top of my head, but there may be others that I'm not thinking of. The best thing to do if neither of these sound right would be to contact the support ninjas so they can examine your sync database, figure out what's going on, and help get this sorted out. Sorry again for the trouble this is causing!

Last edited by Brian; 2009-12-30 at 08:32 AM.. Reason: forgot to include how to get updated version of iPhone app.
 
Thank you so much for the detailed response, Brian.

I noticed another recent thread around the same problem:
http://forums.omnigroup.com/showthread.php?t=14317

I double checked and all my versions are up to date. Also, I noticed that Compact Database under the File menu is disabled, not that I ever do it manually, so I think I can rule that out as what is causing it?

As a precaution for now, based on what I read in the other thread and your response, I disabled auto-sync on the phone. I'm hoping that now I can be sure I'm never changing the database while the phone is syncing.

Thanks for the help! If it happens again I'll send in my sync database for analysis, but I'm confident you guys will be able to fix any of these problems in a future update as always!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error message: Replace your database and start syncing Wordius OmniFocus 1 for Mac 1 2013-01-13 11:07 PM
Message: Replace data base and start syncing [A: contact support.] glen.saberton OmniFocus 1 for Mac 2 2012-10-09 02:32 PM
Replace your database and start syncing? PaulSorensen OmniFocus Syncing 1 2011-10-07 12:23 PM
How to replace Mac database with iPad's? Mads Bjerke OmniFocus Syncing 6 2010-08-07 11:45 AM
Replace your Database and start syncing? after 1.7.4 update Robbie1702 OmniFocus 1 for Mac 16 2009-11-24 11:11 AM


All times are GMT -8. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.