The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
WebDav problem with OSX Server 10.5 Thread Tools Search this Thread Display Modes
Hi,

I'm having trouble getting Onmifocus to sync with webdav. I've set up a webdav server using OSX Server and can create files on the server when I mount the webdav directory through the finder on my desktop computer. I can also browse to it using Safari on my iPhone so I'm fairly confident that I've got the basic webdav service running correctly. I can sync my Ominfocus with my iphone using bonjour.

When I try to sync using webdav from either device I get the same error:

"Unable to synchronize database with server.

Could not access the WebDAV location <https://...site details../OmniFocus.ofocus-copy-in-progress-aefp6bPIslx/>.

Please make sure that the location set in your Sync preferences actually exists."

The console log on the client has this in it:

06/12/2008 23:03:13 OmniFocus[827] sync terminated with error: {
code = 409;
domain = "com.omnigroup.OmniFocus.XMLData.DAVHTTP.ErrorDoma in";
userInfo = {
NSLocalizedDescription = "Could not access the WebDAV location <https:// <<URL>> /OmniFocus.ofocus-copy-in-progress-aefp6bPIslx/>.";
NSLocalizedRecoverySuggestion = "Please make sure that the location set in your Sync preferences actually exists.";
NSUnderlyingError = {
code = 409;
domain = "com.omnigroup.OmniFocus.XMLData.DAVHTTP.ErrorDoma in";
userInfo = {
NSLocalizedDescription = "Unable to perform WebDAV operation.";
NSLocalizedRecoverySuggestion = "The <<DNS Name>> server returned \U201cconflict\U201d (409) in response to a request to \U201cMKCOL /Omnifocus/Tom/OmniFocus.ofocus-copy-in-progress-aefp6bPIslx\U201d.";
errorData = <....lots of hex...>;
errorDataContentType = "text/html; charset=iso-8859-1";
errorString = "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<HTML><HEAD>\n<TITLE>409 Conflict</TITLE>\n</HEAD><BODY>\n<H1>Conflict</H1>\nMissing one or more intermediate collections. Cannot create resource /<<path>>/OmniFocus.ofocus-copy-in-progress-aefp6bPIslx. [409, #0]<P>\n<HR>\n<ADDRESS>Apache/1.3.41 Server at <<DNS Name>> Port 443</ADDRESS>\n</BODY></HTML>\n";
};
};
};
}

The apache eror log on the server has this to offer:

[Sat Dec 6 23:20:00 2008] [error] [client 10.0.0.27] (2)No such file or directory: Missing one or more intermediate collections. Cannot create resource <<path>>/OmniFocus.ofocus-copy-in-progress-ir5D6YOs7ih. [409, #0]


Help: what have I missed? I'm running out of ideas!

Tom
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync problem using Windows Home Server for WebDAV invictus26 Other WebDAV 8 2010-08-28 09:18 AM
WebDAV "method not allowed" (405) [server-side problem] joeminkie OmniFocus for iPhone 1 2010-08-17 11:03 AM
WebDav with OSX Server Tom Henderson Other WebDAV 7 2008-12-19 02:45 PM
WebDAV server dmcg Other WebDAV 0 2008-07-10 11:33 AM


All times are GMT -8. The time now is 09:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.