The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
DB Conflict Solution That Finally Got Sync Working For Me...So Far Thread Tools Search this Thread Display Modes
Oiden is my current hero for spelling this out step by step. I had already narrowed it down to some sort of DB conflict rather than due directly to the syncing software. So far this is finally working for me. I am tentative still as there have been so many ups and downs in this process.

So far so good though. Props to Oden for taking the time to do this! This certainly beat the few dismissive posts I got essentially implying that because they had it working that I shouldn't be having the problem. Hope you restrict that sort of "help" to your cyber relationships, for your sake.

Thanks Oiden.



Quote:
Originally Posted by oiden View Post
I figured out the same thing, and came up with a workaround:

1. I made a backup copy of my original DB, renaming it something like Omnifocus_original. This is important. Then I deleted the original DB from the Application Support Folder. I also made sure the sync copy on .Mac (I hate the new name MobileMe) was deleted.

2. Then I installed a fresh copy of OF/iPhone on the iPhone and selected New Database for the iPhone (local copy) as it starts up for the first time. I then synced that to the iDisk, and then synced the iDisk to my Laptop copy of OF. Everything synced, so far so good, because all was a fresh unused copy of OF (with default actions.).

3. Now I have a sync-able DB of OF on my laptop, created originally on the iPhone. Next I opened that database, and also opened the "original database" by double clicking on it. Both are opened in separate windows on the desktop.

4. Now delete all the "starter" actions from the empty database, making it truly empty. Now go over to the original database's sidebar, and click your project, or folder full of projects, and option-c (copy) that. Mouse over to the empty database, and paste these in that sidebar. Do this as many times as you need to to get everything there.

5. I synced a few times during that process, up to the .Mac and then down to the iPhone, and sure enough, everything ended up on the iPhone looking great.

6. Last I did need to click in the contexts sidebars, and "clean up a little" there, as several contexts showed up with no title. Click the untitled context, figure out what it is and then just title it. All this synced just fine.

It took 2 days to figure out to do this, figuring out that the 1.1 upgraded DB was the culprit. But it only took roughly an hour to finally implement it. Hope this can save somebody several hours of figuring things out.

Last edited by MichaelG; 2008-07-13 at 01:27 PM..
 
Still so far so good. Some hiccups here and there, but at an acceptable and still largely functional level. Nowhere near the back and forth data loss I was getting before implementing Oiden's suggestions. His hero status lives on...
 
MichaelG...that's awesome, I'm glad to hear its working for you too. Still going for me too, syncing back and forth. See my PM about your other questions...
 
Hey oiden. No PM so far. If you haven't sent, pls resend.
 
Hey .. this has worn me out as well the last couple days, but everything still is working for me after I did what I wrote in that first post. Near as I can tell, the iPhone DB syncs automatically to the iDisk just "every so often" or usually when I start up the program on the phone. The DB on the laptop however, seems to need to be synced manually (and I've added the "sync button" to teh toolbar to make that easier. BUT I am not sure about all this, cause I have played with it so much that I never give it time to act alone. All that is sure is that it is still syncing correctly, when before I did that copy/paste thing, nothing would sync...

Tonite I was planning on adding some test actions and contexts to my phone DB and also different ones to the laptop DB.... then do nothing else, no syncing anything manually before going to bed, but I'll leave the laptop DB launched. Then I'll see in the morning if everything synced both ways. I thought I read somewhere that the Desktop 1.1 DB would sync itself every 24 hours, if you did nothing.

Also, syncing DOES seems to occur from whichever direction the latest change was. And I've noticed one weird error on the laptop that says "database not readable"... but a second try always works. I am wondering if that was because I was syncing the desktop to the iDisk, when the iPhone was simultaneously syncing...

I hope that answers your questions. Feel free to hit me back if you need to.
 
I'm getting the periodic hiccup as well, which is to be expected. This is nice having this largely working. I didn't do the exact procedure you did. I couldn't. So i just deleted everything, reset the iphone and started fresh. Pretty much functioned as a weekly review. I probably didn't remember everything, but it'll come back.

Good luck with your overnight experiment. You know things are going more smoothly when you move on to the details like this.

Take care,

MG
 
Thank you so much for this solution, Oiden! You rescued me from a couple of hours of frustration. All's working fine, now!

Best,
Kenn
 
Kenn. glad yours is working. It is a good feeling. As I've said elsewhere, it is truly a home run combo when things are synching. Hard too see how something like location aware contexts and synching back to the mothership could not be in the future of electronic GTD.

Mine unfortunately developed a new problem. When the iphone syncs endlessly so I have to reset the iphone to get out of it. Often when I do that OFiphone hangs permanently on the load screen, and the only way out is to delete the app and start over. I'm back out of the game for now.

At this point I'm going to hold off on trying to synch anymore until there is a new version of OFiphone. It's not even really tempting to try anymore for me since it is resulting in some sort of crash, and often a fatal one with every attempt. I'll take that as my cue to have a seat on the bench for a bit.
 
Wow, Michael, mine is still working and synching as it should... since I did that method a few days ago. I did NOT, however upgrade my desktop OF with the newer sneakypeeks that were released, I just didn't want to take any chances... we must have different setup somewhere along the line...

Kenn, glad to help!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible to create a sync conflict? Danworld OmniFocus Syncing 5 2012-03-22 01:39 PM
Sync Server Problem (with solution) ShawnLevasseur OmniFocus 1 for Mac 0 2011-11-04 06:27 AM
Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] ajgilbert Bonjour sync 4 2009-06-21 09:46 AM
New iCal format? Conflict with OF?? pvonk iCal Sync 0 2008-09-22 05:53 AM
Potential conflict with Quicksilver ksrhee OmniFocus 1 for Mac 9 2007-10-14 06:33 PM


All times are GMT -8. The time now is 10:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.