The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
impressed, but ...I Thread Tools Search this Thread Display Modes
I'm impressed by the rendering speed of OW, but the fact that it isn't recognized by a number of sites as being valid keeps my from purchasing it. Take a look at http://www.cnn.com/video/#/video/cri...ding.insession. Do I have something configured incorrectly to keep CNN from wanting to serve me video? I'm sure there's a "switch" to trick sites in believing OW is Safari or IE or some such, but it seems to be silly to have to do so ...

Again, am I missing something?
 
This is just CNN.com being crappy with their website. They're detecting for a particular browser.

While on the CNN page with the video you want to see, open the site preferences (Option-Command-,) and change the "Identify to web servers and scripts as" from OmniWeb to Safari 3.0.4 (or any other CNN supported browser) and reload the page. The video will load and play just fine.

ape
 
Yes, when websites must resort to identifying the browser being used to display a page they should be using the rendering engine as a reference. Not the browser. We already go a good length to overcome this as we include "Safari" in our user agent string but it isn't perfect.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 04:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.