The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
+omnifocus mail rules broken in 10.5? Thread Tools Search this Thread Display Modes
Safari is no longer in beta. I just noticed my mail rule doesn't work any more. Symptoms exactly as described above. Am I alone? :)
 
The Safari problem was fixed months ago. If your having a similar problem now it probably isn't related to Safari. You can use Help → Send Feedback to contact the support ninjas for help, or look for other forum threads on Mail rules.

Cheers,

Curt
__________________
Cheers,

Curt
 
I just started having this problem last week. I used this successfully multiple times a day for a year, and then it just stopped working.

I have uninstalled and reinstalled the rule; no joy.
 
I'm having this problem as well. Since updating to OF 1.7.5, OF Mail Rule does not functions unless Mail.app message is selected and rule is manually invoked via Message > Apply Rules.

Properly formatted email is sent and received in Mail.app Inbox, but OF Mail Rule fails to trigger. This issue may have been present in previous OF 1.7.x versions—I don't recall testing the Mail Rule in recent versions—but the feature was working properly in 1.7.

Disabling Mail Rule in OF; removing OF Mail Rule in Mail.app; uninstalling MailTags 2.3.1 and Mail Act-On 2.0.5; then re-enabling Mail Rule in OF fail to resolve issue.

OF 1.7.5
OS X 10.5.8, PPC

Feedback sent to Support Ninjas.
 
I can confirm that I am seeing the same thing. The rule worked 2 days ago with 1.7.4, but is now broken with 1.7.5.
 
It is now working again, but I don't know what it was about what I did that made a difference. Here are the steps I took:

1) Deleted 1.7.5 and installed 1.7.4 from a TM backup, mail rule works
2) Deleted 1.7.4 and installed 1.7.5 SP #1 from a TM backup, mail rule works.
3) Ran 'Check for updates' from SP #1 and selected 1.7.5 SP #2, mail rule works (previously I had never installed the second 1.7.5 SP build)
4) Ran 'Check for updates from SP #2 and selected 1.7.5 final, mail rule works

Not once during the above did I open the OmniFocus preferences, Mail preferences, etc. or otherwise change anything other than installing a different version of OmniFocus. @kaijin, you might try re-installing 1.7.5 from a fresh download and see if that helps.
 
I tried re-installing 1.7.5, but OF Mail Rule still does not function unless the rule is manually applied to message.

I switched from POP to IMAP between OF 1.7 and OF 1.7.5. I don't see how that would impact the OF Mail Rule, but perhaps it's a pertinent detail.
 
Additional information:
When using web-based gmail, then downloading the message in Mail.app, the OF Mail Rule is correctly triggered and the OF task is created.

Using Mail.app to send and receive a test message continues to fail to trigger the OF Mail Rule. (I've successfully done this in the past to test the rule).

Submitted to Support Ninjas
 
Just a quick check, since you were using different programs to send the mail -- you do have the source address used by Mail.app when you sent your test message in the list of allowable email addresses, right?
 
Quote:
Originally Posted by whpalmer4 View Post
Just a quick check, since you were using different programs to send the mail -- you do have the source address used by Mail.app when you sent your test message in the list of allowable email addresses, right?
Yes, all addresses I've used to test the OF Mail Rule in 1.7.5 are included in the Allowed list in OF preferences.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to process mail with attachments with mail rules. bjgreenberg OmniFocus 1 for Mac 2 2011-08-26 01:39 PM
Custom Mail.app rules? Frank M Omni Lounge 2 2010-09-10 10:10 PM
adding +omnifocus for mail rules - Apple problem? mhedstrom OmniFocus 1 for Mac 12 2008-08-08 08:26 PM
Help: Mail crashes after adding mail rules corin OmniFocus 1 for Mac 4 2007-12-12 06:36 PM
Mail rules gg42 OmniFocus 1 for Mac 0 2007-11-17 09:16 PM


All times are GMT -8. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.