The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Cleanup help Thread Tools Search this Thread Display Modes
Is there any way to prevent OF from cleaning up entries as soon as you enter a context/project? I find that as I am entering a new action, the action moves as soon as I enter this information and it deselects the next text entry box (Start date) and selects the entire action. I then have to re-enter the text field to complete entering information about the action. In addition, it is confusing to have the action jump around.

It would be nice if I could enter all of the columns of information before it cleaned up or if it only cleaned up after I hit Return, rather than Tab which I expect to go to the next text field.

Thanks!
kman
 
Kman, what screen are you on when this happens? I was able to add test actions in project view, context view, and the quick entry window without having the action jump around.

It sounds like a bug, but I'm wondering if there's a particular perspective I need to be in, or a particular set of view menu settings I need to have in order to tickle this. Once we can reproduce the issue, it's a lot easier for the team to fix. Thanks for the help with this, and I'm sorry for the trouble it's causing!
 
Well, I just had it happen in a custom perspective with the following attributes: View mode is context; restore focus, layout, expansion, and selection, but not settings; focus is no focus; context filter is remaining; group actions by context; sort actions by due; status is available; duration is any; flagged is any. The perspective has focus on a three different contexts.

When I started entering a new item it jumped away as soon as I entered the context.
 
Perhaps the new action was not "available"? If it's not, it won't appear in your perspective.

-Dennis
 
It appears in the window. It's just jumping around as I'm entering it.
 
I usually enter my actions in project view or the Inbox, but I recently had this happen also when I was in a custom perspective. The settings were: context view mode, no focus, active, flagged, due, available, any, any. This perspective shows all of my available actions, separated by Flagged first and Unflagged second. Within each section, the tasks are sorted by due date first (most overdue or closest to being due first) followed by tasks without due dates (which are further sorted by project).

First, no matter where I am in the list with a highlighted line, when I select "Add Action" the new line is entered at the very bottom of the list. Then, after I enter the task information - if I flag the task, it immediately jumps to the bottom of the Flagged section at the top of the list. If I select a project, it immediately jumps where other available tasks in that project are in the unflagged section (since I didn't have a chance to flag it). If I select a start date or due date, the task does not move immediately, but may move when another task moves.

It appears to me that if the attribute I attach to the task is sortable or filtered in that perspective/view, then the task moves. There seems to be no "clean up" function for new tasks in these views.
 
Quote:
Originally Posted by kman42 View Post
Well, I just had it happen in a custom perspective with the following attributes: View mode is context; restore focus, layout, expansion, and selection, but not settings; focus is no focus; context filter is remaining; group actions by context; sort actions by due; status is available; duration is any; flagged is any. The perspective has focus on a three different contexts.

When I started entering a new item it jumped away as soon as I entered the context.
Hmmm... there's something I'm missing here - I set up a perspective like this and initially had trouble reproducing the issue because I didn't have the context column visible.

Added that column, tried again. Hit return to add a new action, which appeared at the top of the screen. Typed in a title, set the project, set the context, all from the keyboard. (Filling out the field, then hitting right-arrow to go to the next cell.)

Made sure to set the context to one of the ones that the perspective doesn't focus on. Still couldn't get the new action didn't move until I hit the Clean up button on the toolbar.

Since you are able to consistently tickle the bug, would you be able to send screenshots to the support ninjas, taken immediately before and after you trigger it?

You can take a screenshot by pressing command-shift-4, which will give you a selection cursor. Tap your Space key, click on the window you want to capture, and when you release the mouse the image will be saved to your desktop as 'Picture 1', 'Picture 2', etc.

This definitely isn't intended behavior - I'm just having a heck of a time getting it to happen for some reason. Really appreciate the help!
 
Quote:
Originally Posted by dpvanwormer View Post
if I flag the task, it immediately jumps to the bottom of the Flagged section at the top of the list. If I select a project, it immediately jumps where other available tasks in that project are in the unflagged section (since I didn't have a chance to flag it).
Thanks for this - I was able to reproduce the "jumps when the action is flagged" behavior. (I flagged the new action via the mouse; let me know if you were using a different method.)

One clarification: where you say "select a project" - I assume that means you're assigning a project to the new action, yes? On first reading, I thought you meant selecting a project via mouse or keyboard, but projects don't appear in context view perspectives...

For whatever reason, I wasn't able to get actions to jump around when I typed in start dates, due dates, or projects.

Quote:
Originally Posted by dpvanwormer View Post
If I select a start date or due date, the task does not move immediately, but may move when another task moves.
The intended behavior is that actions that are created in the "wrong" places according to the window settings stay where they are. When a Clean Up is triggered from the toolbar or the keyboard shortcut, they all move to the "right" places en masse.

Flagging an action with the mouse is also triggering a Clean Up - it sounds like there are a couple other cases out there that are doing so.

If we can nail down those other triggers, I can file bugs on them, as well.
 
Okay, I think I may have cracked this one - are you guys using the drop down menus to set your projects/context/dates? Is the fact that I'm typing them in and using the autocomplete the reason I'm having trouble reproducing this?
 
Okay, now I really think I have it figured out - it happens when editing an existing row, vs. with a newly-created row. Can you guys confirm that?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backup Cleanup gryphonent OmniFocus 1 for Mac 46 2011-12-27 11:30 AM
Cleanup is not cleaning joeworkman OmniFocus 1 for Mac 4 2008-07-17 09:54 PM
Where is auto-cleanup? santra OmniFocus 1 for Mac 1 2008-03-24 03:52 AM
Bug in latest build (cleanup) Somebee OmniFocus 1 for Mac 12 2007-11-06 01:15 AM
Confused about cleanup santra OmniFocus 1 for Mac 5 2007-09-30 08:34 PM


All times are GMT -8. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.