The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Sync between iPhone and MobileMe won't work over 3G Thread Tools Search this Thread Display Modes
Hi all,

Loving the Omnifocus way of life!

When I sync the iPhone via WiFi it all works quite well. However, when I try to sync over 3G it just sits there and either gives up or says "Error: cannot find host."

Is this a network issue or something else? I can access the internet with other apps in the same spot, so it isn't a coverage issue.

Is there a way to diagnose what is going on?

I am in Canada on the Rogers network.

Thanks so much!!

- Aaron
 
All of the communications at that level is dealt with by the phone. I'm afraid I can't think of any way to diagnose it.

The one thing that I can think of is that maybe you're using HTTPS for syncing? (This would be the case for iDisk syncing, or WebDAV if you've specified HTTPS.) If so, make sure that you can also do HTTPS in your web browser over 3G, by going to a secure web site. (I expect you to be able to do HTTPS fine, it's just the only thing I could think of that might be different in OmniFocus from "normal" web browsing.)
 
What server are you syncing the iPhone to? If you're running a WebDAV server on your computer, then your iPhone probably won't be able to see it over 3G unless you have your computer and firewall and DNS all configured properly for that.
 
I am having the same problem but in reverse. It started happening this summer. I am always able to sync OmniFocus for Mac with the database through MobileMe. I can also sync my iPhone version through MobileMe over 3G, but most of the time the sync fails when my iPhone is connected via WiFi. I get this message: "Unable to synchronize database with server, can't find host."
 
Did you change your networking setup, like installing a new access point or router, or firmware for same? If you go to the Settings page to set up Bonjour sync on the iPhone when connected by WiFi, and click the Share Settings button on the Mac, is the iPhone able to find the server? My guess is the answer is no.

Potential head-slapping moment: you do have the Mac application running and configured for Bonjour sync when you are doing this, right? It's an easy thing to forget if you're used to MobileMe's always-available sync...
 
I don't think it is a problem with OmniFocus settings, because using MobileMe to sync over WiFi works sometimes. Most of the time, though, it doesn't. (Again, it always works for me over 3G network.)
 
No, not the OmniFocus settings, but firewall settings on your Mac, or your router/access point. You'll get that same error if the packets used to find the OmniFocus server are blocked somewhere between Mac and iPhone. You might want to contact the Omni support ninjas for help in troubleshooting this. 1-800-315-OMNI or omnifocus@omnigroup.com.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some perspectives won't sync with iPhone 4 via MobileMe simon_elearning OmniFocus Syncing 2 2010-08-05 10:53 PM
iPhone will not sync through MobileMe kwildes OmniFocus for iPhone 1 2009-10-30 02:24 PM
iPhone will not sync through MobileMe kwildes OmniFocus for iPhone 1 2009-10-26 09:25 PM
MobileMe sync issues with iPhone getmethebutter OmniFocus for iPhone 3 2009-07-12 10:39 AM
Easy iPhone Sync Fix for MobileMe iannarino iDisk/MobileMe/.Mac Syncing 4 2008-08-08 06:05 AM


All times are GMT -8. The time now is 08:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.