The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Building xcd2odo from OmniDataObjects Thread Tools Search this Thread Display Modes
Hi there, I've managed to build the frameworks fine, and with the helpful note from the blog, have managed to get required Omni source building for an iPhone app.

I want to use the xcd2odo tool so that I can create my data model in the Xcode data model editor - I'm presuming that's what its for.

I can't seem to get the xcd2odo to build in the OmniDataObjects project.

Bizarrely it is claiming that it can't find <OmniBase/OBObject.h> and a bunch of other headers. All the relevant Frameworks are correctly referenced in the project, pointing to the default build location of /Users/Shared/<user name>/Installed Products/

I've switched to the xcd2odo target, the relevant OmniFrameworks are included in the target's linked binaries.

Is there any internal Omni configuration required to get executables to build from what is released in the public Frameworks?
 
All the xcconfig files are present in the source release, but they should already be all hooked up to the xcd2odo tool's build settings.

It's also worth noting (I'll post another thread about this) that a newer build of our frameworks (including some big improvements to ODO) have been posted on github at <http://github.com/omnigroup/omnigroup/>

I'm still experimenting with github, but so far it looks like a reasonable way to distribute our sources.
__________________
CTO, The Omni Group
 
Looks like the Mac developer community are embracing Git the way they initially embrace SVN. Should work nicely with my workflow as I've just adopted Git for this new project.

Thanks
 
Quote:
Originally Posted by ssanchez View Post
Hi there, I've managed to build the frameworks fine, and with the helpful note from the blog, have managed to get required Omni source building for an iPhone app.

I want to use the xcd2odo tool so that I can create my data model in the Xcode data model editor - I'm presuming that's what its for.

I can't seem to get the xcd2odo to build in the OmniDataObjects project.

Bizarrely it is claiming that it can't find <OmniBase/OBObject.h> and a bunch of other headers. All the relevant Frameworks are correctly referenced in the project, pointing to the default build location of /Users/Shared/<user name>/Installed Products/

I've switched to the xcd2odo target, the relevant OmniFrameworks are included in the target's linked binaries.

Is there any internal Omni configuration required to get executables to build from what is released in the public Frameworks?
I was able to get this working by adding /Users/Shared/<user name>/Products to the Framework Search Paths in Search Paths section of the build.
 
Ignore my previous answer! Following on from http://forums.omnigroup.com/showthre...t=intermediate you need to set the Build Products Path in the project build settings to /Users/Shared<user name>/Products/
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building for 10.5 Joe Alexander Omni Frameworks 3 2011-05-15 10:47 AM
Building an integrated PIM on a Mac. Diver T Applying OmniFocus 5 2010-01-18 04:33 PM
Building frameworks for the first time... Craig Hockenberry Omni Frameworks 6 2009-04-07 09:21 PM
using OG for building layouts jtharveyjr OmniGraffle General 0 2007-03-03 08:46 AM
error building kidtexas Omni Frameworks 3 2006-09-05 04:29 PM


All times are GMT -8. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.