The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

SOLVED: Not syncing from iPhone > iDisk > Mac Thread Tools Search this Thread Display Modes
Marking actions as done on iPhone but not always syncing back to Mac correctly. iPhone definitely talking to server. Server not definitely talking to Mac. Have manually synced several times to force an update but action I marked completed several hours ago on iPhone marked as overdue on Mac! Worked fine for first few days I had app but after daily beta updates nothing appears consistent.

Also, I am subscribing to threads and getting no notifications of replies/answers. Lots of things NOT happening at the moment!! Please sort out as I have spent over 60 on Omni products recently and development/reliability seem to be going backwards.
What happens when you push the Sync button on your Mac? How far does the progress indicator get? Are there any error messages in Console?

If you create an action on the Mac, can you sync it up to the server and then sync your iPhone and see it on your iPhone?

I know you're looking for answers, not more questions, but there are a lot of possible things that could be wrong, and a few more details can help us narrow down the possibilities.
Hi mate, am away from my Mac now so can't check error logs. Basically it seems I can create actions either on Mac or iPhone and they will sync either way fairly reliably. Editing or marking as done seem to have varying results.

I set one new task on phone and one new task on Mac and within minutes t they appeared on both devices, however when I mark one on the Mac as read and the other on the phone as read these changes were not reflected on the Mac although both are read on phone.

Just seems a bit inconsitent. Could be a server issue as MobileMe is noT performing great at moment. Hope this narrows it down a litttle, thanks for response and sorry if I sound a little impatient. Have my baby daughter afrer my phone making it difficult to type (or think coherently) :-)
I'm seeing similar things. I've sent two e-mails to support, the first over three days ago, but haven't had a reply yet.

I don't know where this "progress indicator" you mention is Lizard? All I see is the sync button spinning.

How do I get to the logs? I see no mention of Omnifocus in console, but then I don't know what I'm looking for.

The following is part of the report I sent to support. I'm using MobileMe:

Yesterday I added 3 tasks to the inbox, marked several tasks as complete, and edited the title and dates of another, all on the iPhone. I synced several times, apparently successfully, though the very last sync I tried did time out (though there were no changes made between it and the previous sync).

This morning I opened up the desktop version, synced, and found that the only change that had worked was the addition of one task to Inbox - none of the others had worked. Worse still, the iPhone version has now been overwritten by the (older) desktop version, so I've no record of the changes I made.
We're trying to catch up with all those support emails we've been getting. I think we're still about 6 days behind, but catching up!

In Console, there should be a search box. You can type OmniFocus in there and it will filter out messages from other apps.

To turn on some additional logging that might help, you can do the following:

1) Quit OmniFocus
2) Type the following line into Terminal and press return:
defaults write com.omnigroup.OmniFocus XMLFileManagerDebug -bool YES
3) Launch OmniFocus again

If you open up the OmniFocus Sync Preference pane and then sync, it will show a progress indicator.

I see the following in console (repeated):

24/07/2008 24 Jul 08, 01:05:25 OmniFocus[1903] Ignoring tail <XMLTransaction:0x9c4d790> which can't reach a root in <XMLTransactionGraph: 0x9c5efe0> 
24/07/2008 24 Jul 08, 01:05:25 OmniFocus[1903] Disconnected transactions:
But only for today - nothing showing yesterday when I had the problem (I've changed nothing on the iPhone today because I don't trust it). Does that help at all?

I've turned the additional logging on as instructed. What do I do with the logs that result, and where do I find them?

The progress bar stays blank for about 30 seconds, then goes from zero to complete in less than one second. There are no errors.

We've fixed the bug that caused this, but your database still needs to be unscrambled.

Make a backup of the OmniFocus database on your desktop, just in case something goes sideways.

Connect to your sync location and move all of the OmniFocus-related stuff from the Document folder into an archive folder that we can examine later.

Moving that stuff out of your iDisk documents folder means that your synchronization should be back in a pristine, original state.

(If you haven't done so yet, you may want to use the new "Archive Old Data..." feature we added to version 1.1; it will reduce the amount of data we're syncing to the iPhone, while keeping it around on whichever desktop machine you'd like to review the information on.)

Next, try synchronizing from whichever one of your desktop machines has the most up-to-date information to make sure that works. Maybe synchronize one more time to make sure it still works.

If you look at your iDisk at this point, you should have a single OmniFocus.ofocus folder inside your Documents folder; you shouldn't have any "copy-in-progress" files lying around, for example.

One by one, go to the rest of your desktop computers and sync. You may be asked to replace your local copy with the server copy; if so, say yes. Sync again, to make sure that's solid. Go back to your desktop and sync there.

Everything still working? Try changing something, and sync on both sides to see if the other side sees the change.

Now try adding your iPhone to the mix. Make sure your iPhone is running version 1.0.1 (at the bottom of the Settings pane). Start a Sync. Once it completes, quit and restart the iPhone app. Do sync changes behave as expected now?

Same problem here. I did everything you suggested above. I got a clean copy on MobileMe and whenever i try to sync again the sync button just keeps spinning and nothing happens, It could literally spin for hours with no error messages at all the progress bar never moves and it's greyed out. I've been going through this for days now. I have the latest "snecky peak" build update it every day, also have the same on the latest on the iphone too. I always get the fresh copy up to mobileme but any attempts to sync after I get the fresh copy up fail on both the desktop and iphone. I always try to sync the desktop first to see if it's working, never does...... Please Help!!!

Many Thanx
dryver8: The 'defaults' command I posted above should be spewing all kinds of data to the Console. Could you email that to (If you put "For Lizard" in the subject line, I'll be able to find it easier.)

It'd also be really helpful if you could include the output from the following command:

ls -1 "~/Library/Application Support/OmniFocus/OmniFocus.ofocus"
Wow, ell and one look really similar in that font. It's ell ess space dash one. Or just copy and paste. :)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] codog24 iDisk/MobileMe/.Mac Syncing 27 2009-09-01 05:21 PM
My iTouch data is not syncing [SOLVED] Night_Sailor OmniFocus Syncing 2 2009-04-25 05:11 PM
[SOLVED] new update gives me eternal syncing DonLivingston OmniFocus Syncing 27 2008-09-04 07:23 AM
SOLVED: iphone items NOT syncing to mac Devo777 OmniFocus Syncing 5 2008-07-29 12:42 PM
iDisk syncing Treo iDisk/MobileMe/.Mac Syncing 7 2008-07-18 12:07 AM

All times are GMT -8. The time now is 08:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.