The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Memory leak? Thread Tools Search this Thread Display Modes
I've all but dumped Safari / Firefox in favour of the SP releases, but one thing is still driving me insane - it appears to hi-jack my MacBook as the day goes on. Check with Activity Monitor, and it seems to double its use of memory from morning through to the afternoon, to the point where other apps as sluggish and OW itself requires a force quit.

Am I alone here, or is there actually a problem?

Thanks,

Mark
 
We haven't done a memory leak pass recently. Also we haven't verified our cache settings so there might be an issue there as well.
 
I'm still getting the slowdown I've seen in most (all?) of the SPs. I'm going to restart OW after this post. When I type, there's even a lag.

I know this isn't the most accurate measure but:
24158 OmniWeb 71.5% 3:32:02 22 324 5304 939M+ 193M 1022M+ 1.68G

It's using almost 1GB of real and 1.68GB of virtual. And without even surfing, it's using 71.5% of the CPU on a dual 2.7.
 
I'm experiencing similar memory leaks as well. In no time OW is using 300 - 400 mb real memory. Back to Safari for now :-(
 
Interesting on my G4 powerbook after 11 days of up time and Omniweb always in use I have 0% CPU usage (when doing nothing) 239mb of real memory usage and 1,57gb of virtual memory. This is with SP11. My mem & CPU usage seems very different but why?
 
It varies based on the sites you visit. If I go to newegg.com, I immediately get high CPU usage after viewing a few pages. If I stay on just a few sites, I can have OW up for days.
 
One of my workspaces consistently triggers abnormally high CPU usage (it will jump between 20 to 40% and make everything very sluggish) and it's been doing it ever since the first sp. The only way to clear it is to quit and re-launch. If I avoid that Workspace, it doesn't seem to happen as often. Unfortunately, that particular Workspace is one I visit a lot, so I am unable to have OmniWeb open for more than about 30 minutes a go...
 
Yes, there is most definitely a memory leak. After a few hours of using OW, my entire system slows to a crawl. After quitting OW, everything is back to normal. I've been able to confirm this many times.
 
Quote:
Originally Posted by Forrest
It varies based on the sites you visit. If I go to newegg.com, I immediately get high CPU usage after viewing a few pages. If I stay on just a few sites, I can have OW up for days.
Interesting, if I go to newegg and open up a dozen or so tabs and flick between them I seem to use up around 25 - 30 mb or real memory but closing the tabs seems to release it all again. The cpu usage with 13 tabs open increases to 5-6% on the pages with flashing publicity but remains around 2-3% on those with out it.

Is it possibile that the problem is connected to the processor type, I don't see how but I just don't seem to have the same problems as some others here?
 
My original post failed to include specs - I'm running a MacBook Pro with 1GB RAM and a 1.83GHz processor.

Since my first post, I've compared OW SP11 to the version running on my PPC Mac Mini - the latter, even after running for two hours and opening lots of tabs, seems to never go above 85MB of real memory. Today at the office, SP11 on the Intel MBP was eating over 160MB (and climbing) before I quit.

Maybe it is a processor issue?
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible memory leak in Leopard? Target1 OmniOutliner 3 for Mac 2 2007-10-31 08:35 AM
OW 5.6 sp 5 - memory leak with Gmail? mihnat OmniWeb Bug Reports 1 2007-09-03 06:26 PM
Memory Leak only120xs OmniWeb Bug Reports 8 2006-10-17 08:40 AM
possible memory leak andreas_g OmniWeb Bug Reports 6 2006-05-26 10:06 AM
[sp4] Memory leak?? Cortig OmniWeb Bug Reports 26 2006-05-06 12:12 PM


All times are GMT -8. The time now is 02:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.