The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? Thread Tools Search this Thread Display Modes
Hi, I had this same problem. Deleting the keychain on my mac fixed it there, however going to the link on my iPhone didn't resolve the issue.

I found a different link elsewhere on the forums that worked:

Hope this helps somebody.
When trying to sync with Mobileme I get an error message:

The server returned "forbidden" (403) in response to a request to PROPFIND

Does anyone know what this error message means and how to resolve?
Tried everything out, deleted database from my iPhone, tried various other methods, nothing works.

Help would be very appreciated, can't gtd without this thing :).

By the way, link in post above doesn't work :(
Problem solved! Deleted and reinstalled OmniFocus on my iPhone. I hope it wouldn't fail again :).

Sorry for bothering
Originally Posted by Lizard View Post
Also, check your keychain for any stored passwords for your old MobileMe account and remove them.

I have now got two MobileMe accounts. I wanted to use the new one for syncing to iPod Touch but I can't because of the Forbidden (403) error.

I don't wish to remove stored passwords for my "old" MobileMe account.

I have removed the password for the "old" MobileMe account itself, but there are quite a few others relating to that one. Removing the old account password has not made syncing possible.

I'm now syncing using Bonjour instead which is far from ideal.
Patrick - I would contact the support ninjas about this; we collectively browse the forums as we're able, but I'm a couple of time zones removed from the rest of the team right now. If you email the ninjas, you're guaranteed a response from the folks that can poke a developer and see what to do here...
Originally Posted by Brian View Post
Patrick - I would contact the support ninjas about this
Thank you Brian, I will do :)
It took a while to figure out, and like others, I went into Keychain first thinking that was the source of my problem. I tried to make sure OmniFocus had access to my new iDisk keychain password, and manually added it, but to no avail. I finally fixed this problem doing the following:

(1) Open Keychain from the following location: /Applications/Utilities/Keychain
(2) Locate the key with the following properties: Name - (<username> ; Kind - Internet Password ; Keychain - login.
(3) To be certain you're working with the correct Key, double-click on the key to bring up it's attributes.
(4) Select the Access Control tab
(5) If the Access Control list ONLY includes OmniFocus, you're definitely working with the correct key.
(6) Close the key, then right click or ctrl+click on the item.
(7) Delete the key from Keychain.
(8) Launch OmniFocus and go to the menu OmniFocus>Preferences>Sync
(9) Click the "Show Clients" button. When doing so, it should prompt for the MobileMe username and password. If it does not, you've likely deleted the wrong key.
(10) After entering the correct username & password, press "Sync" and it should connect and sync to the proper MobileMe iDisk location.

Hope that helps! :)
Originally Posted by Brian View Post
It appears that the user name and password that OmniFocus for iPhone uses can get stuck on a particular value. If you enter a typo or if your login information changes, OmniFocus gets stuck using the bad/old information.

We're going to add some code in our next update that manually prompts you for another user name and password combo when we get a "403 forbidden" response to a sync.

For the time being, though, we'll work around the problem by doing the following:
In OmniFocus' settings screen, scroll down to the sync settings.
Tap "advanced", then enter "" into the "Location" field.
Tap 'done', then tap the sync button.

Your phone will attempt to contact our server for a sync; we'll prompt the phone to ask you for a new login and password.

Type in random gibberish for the user name and password - the point here is that we want our server to send you a 'bad password' response. (Do not type in the user name and password of the *account you're actually trying to sync with; we could read that data.)

In any case, when the password sheet comes down a second time, tap 'cancel', then set the phone up with the correct sync address and start a sync.

You should be asked for the user name and password to your sync location. Enter the new information and you should be back up and running.
I've attempted this method twice to no avail. It seems that there is omnifocus data being saved regardless of whether I delete the application and reinstall. Your assistance to solve this is greatly appreciated
Yeah, you don't want to delete and reinstall, you want to do what Brian suggested, or visit this page (from your device that is having trouble syncing):

The faulty data is stored in a place that isn't affected by deleting and reinstalling the application.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] codog24 iDisk/MobileMe/.Mac Syncing 27 2009-09-01 05:21 PM
Solving MobileMe/iDisk "Root Transactions" problems Brian iDisk/MobileMe/.Mac Syncing 0 2009-05-13 05:38 PM
Sync: server returned an error 403 "forbidden" fishwind OmniFocus for iPhone 6 2008-08-08 12:16 PM
Unable to Sync - Error 403 "forbidden" fishwind OmniFocus Syncing 2 2008-07-17 01:10 AM
Error 403, "Forbidden" with Zimbra 5.0 braver OmniFocus Syncing 1 2008-07-13 03:42 AM

All times are GMT -8. The time now is 07:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.