The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OW Sneaky Peeks and keychain Thread Tools Search this Thread Display Modes
It is still in the release notes that saving to the keychain may not work. I have yet to see this work properly with any of the SP builds.

I also note that reading from the keychain also may not work. When the transition was made from .dotmac to mobileme, the authentication changed to go through auth.apple.com. Under MacOS 10.4.11 or 10.5.4, the mobileme login password cannot be saved via OW. However, I manually created the correct password entry using Keychain access. OW sneaky peeks will only autofill the entry properly from 10.4.11 keychain and will not fill from the 10.5.4 keychain. The entries are identical, and the overall keychain prefs are the same. 10.5.4 also prompts to save the PW every time, so it's not seeing the PW at all.

Craig
 
I second that. One of the reasons I like to use OW rather than Opera or Firefox is the keychain. Without the integration working properly, I canít really stay on OmniWeb.

Any official word about it? What is the problem? It used to work before, after all Ö

Cheers,
-Sascha
 
I believe the problem is related to Code Signing of OmniWeb, The fix will be included in the final 5.8 release. If it's preventing you from using OmniWeb you can always go back to 5.7.

Sorry for the inconvenience this can cause.
 
Quote:
Originally Posted by troyb View Post
I believe the problem is related to Code Signing of OmniWeb, The fix will be included in the final 5.8 release. If it's preventing you from using OmniWeb you can always go back to 5.7.

Sorry for the inconvenience this can cause.
Thanks, Troy. Is this the cause of failure to read from the keychain under Leopard, also?
 
Reading should work fine. On the authentication page for me.com, I was able to successfully save credentials in OmniWeb 5.7 and then have them restored in the sneaky peeks.
 
Thanks for the heads-up, Troy! Much obliged. :)

Cheers,
-Sascha
 
Thanks, Troy. I tried rolling back to the release version, and it works as expected. The behavior I observed might have something to do with how the keychain entries themselves were formatted. My 10.4 keychain shows this item is an "Internet Password" and the 10.5 keychain item is a "Web Form Password." When I manually created these entries, I used the 10.4 syntax, and OW doesn't like this syntax in Leopard.
 
This may seem strange but iv'e noticed recently there are many of my web form passwords missing from keychain. Im not sure if it is a result of the SP release but they sure were in keychain before this release.
 
OmniWeb never deletes anything from your keychain. Safari however can if you use the "Reset Safari" option.
 
Troy,

I save my important passwords in a separate keychain for easy maintenance. both Safari and OW can see them and use them to automatically fill fields. the problem though is that OW will *always* ask me if I want to save the passwords even though they're already in the keychain. Omni once told me that this is a problem with the OS and Keychain Access, but this *does not happen* with Safari. it's a pain-in-the-neck to always have to click on the Don't Save button.

furthermore, OW *can* delete passwords from the Keychain. if you click the Never button, OW deletes the (first) existing password from the Keychains, replacing the Account value with "Passwords not saved" and deleting the password. so OW can access the keychain and find the key to fill the fields, but cannot see that the key exists to not ask about saving the value, but can see the key to replace and delete it!

theoretically, OW shouldn't be looking into the Keychain to see that a key should not be saved for a particular web site. that preference should be saved in the site's preferences. no?

please fix this, SOON! I've just come back to OW from Safari to see if there have been any improvements in speed and response, but this password thing REALLY BUGS ME!!!

cheers,
Gregory

Last edited by Gregory; 2008-09-03 at 06:05 PM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniWeb 5.11 Sneaky Peeks troyb OmniWeb General 19 2011-05-03 05:31 AM
OmniPlan 1.7 Sneaky Peeks now available! skwirl OmniPlan General 0 2010-10-13 10:18 PM
What's happened to Sneaky Peeks? jwthomas OmniWeb General 3 2010-04-21 04:38 AM
Sneaky Peeks gone? Smithcraft OmniWeb General 5 2007-10-25 05:10 AM
CPU use in sneaky peeks hardcoreUFO OmniWeb Bug Reports 7 2007-08-31 02:23 PM


All times are GMT -8. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.