The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Compiling for iOS 4.2 beta ? Thread Tools Search this Thread Display Modes
I am just getting started exploring this work from Omni (Go OMNI GROUP!), but I have run into an issue that I hope someone might be able to assist me with.

I have downloaded the iOS 4.2 beta 2 for the iPad and I am trying to build this code using that SDK.

The build for FixStringsFile completes.

But, when it tries to build the OmniBase, I get the following error (no iPhoneOS 3.2)

Since I am new to the build process, I was not sure where it is picking up this target. Can anyone make a suggestion on how/where to alter the build config to allow it to use iOS 4.0? Also, has anyone had any luck with this?

Thanks,

Charlie



Building OmniBase (OmniGroup/Frameworks/OmniBase(OmniBaseTouchTests))
+./Scripts/Build:136> xcodebuild 'DSTROOT=/' 'SYMROOT=/Users/Shared/charlie/Products' 'OBJROOT=/Users/Shared/charlie/Products/Builds' 'OMNI_INSTALLED_PRODUCTS=' 'OMNI_FRAMEWORK_TARGET_PATH=/Users/Shared/charlie/Products/Debug' -configuration Debug -target OmniBaseTouchTests -project OmniBase.xcodeproj
Build settings from command line:
DSTROOT = /
OBJROOT = /Users/Shared/charlie/Products/Builds
OMNI_FRAMEWORK_TARGET_PATH = /Users/Shared/charlie/Products/Debug
OMNI_INSTALLED_PRODUCTS =
SYMROOT = /Users/Shared/charlie/Products


=== BUILD NATIVE TARGET OmniBaseTouch OF PROJECT OmniBase WITH CONFIGURATION Debug ===
Check dependencies
error: There is no SDK with the name or path 'iphoneos3.2'
[BEROR]error: There is no SDK with the name or path 'iphoneos3.2'
** BUILD FAILED **

Build failed in (OmniGroup/Frameworks/OmniBase(OmniBaseTouchTests))
office-imac:OmniGroup charlie$
office-imac:OmniGroup charlie$
 
I don't know if this is the *right* thing to do, but I edited 'Configurations/Target-Touch-Common.xconfig' and changed the SDKROOT line to:

SDKROOT = iphoneos4.2

This helps, but I get errors about a deprecated API being called in a couple of files. See below...


Anyone have a 'fix' for these errors?

cc1obj: warnings being treated as errors
In file included from /Users/charlie/OmniGroup/Frameworks/OmniFoundation/OpenStepExtensions.subproj/NSDate-OFExtensions.m:8:
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h: In function 'OFDateByAddingTimeInterval':
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h:53: warning: 'addTimeInterval:' is deprecated (declared at /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.2.sdk/System/Library/Frameworks/Foundation.framework/Headers/NSDate.h:27)
CompileC /Users/Shared/charlie/Products/Builds/OmniFoundation.build/Debug-iphoneos/OmniFoundationTouch.build/Objects-normal/armv7/OFPreference.o OFPreference.m normal armv7 objective-c com.apple.compilers.llvmgcc42

cc1obj: warnings being treated as errors
In file included from /Users/charlie/OmniGroup/Frameworks/OmniFoundation/OFPreference.m:13:
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h: In function 'OFDateByAddingTimeInterval':
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h:53: warning: 'addTimeInterval:' is deprecated (declared at /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.2.sdk/System/Library/Frameworks/Foundation.framework/Headers/NSDate.h:27)
CompileC /Users/Shared/charlie/Products/Builds/OmniFoundation.build/Debug-iphoneos/OmniFoundationTouch.build/Objects-normal/armv7/OFXMLElement.o XML/OFXMLElement.m normal armv7 objective-c com.apple.compilers.llvmgcc42

cc1obj: warnings being treated as errors
In file included from /Users/charlie/OmniGroup/Frameworks/OmniFoundation/XML/OFXMLElement.m:17:
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h: In function 'OFDateByAddingTimeInterval':
/Users/Shared/charlie/Products/Debug-iphoneos/include/OmniFoundation/NSDate-OFExtensions.h:53: warning: 'addTimeInterval:' is deprecated (declared at /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.2.sdk/System/Library/Frameworks/Foundation.framework/Headers/NSDate.h:27)
PhaseScriptExecution "Build Strings" /Users/Shared/charlie/Products/Builds/OmniFoundation.build/Debug-iphoneos/OmniFoundationTouch.build/Script-3444F47F11921ABF0003AD7F.sh
cd /Users/charlie/OmniGroup/Frameworks/OmniFoundation
/bin/sh -c /Users/Shared/charlie/Products/Builds/OmniFoundation.build/Debug-iphoneos/OmniFoundationTouch.build/Script-3444F47F11921ABF0003AD7F.sh
 
Ok, a quick clean (./Scripts/Build Frameworks/ clean')

and then edit Frameworks/OmniFoundation/OpenStepExtensions.subproj/NSDate-OFExtensions.h

And comment out the offending line(s) ...

And a recompile .... (./Scripts/Build Frameworks/)

clears that up...
 
Yes, setting the SDK in the xcconfig is correct. We have a bunch of changes (including some for 4.2) that we need to pull over to github, hopefully in the near future. But, if you've got a building system, it should let you explore and decide if there are bits of code useful to your project.
__________________
CTO, The Omni Group
 
Back to looking at this, I am now looking to build the actual example application.

Opened /Users/poweruser/OmniGroup/Frameworks/OmniUI/iPad/Examples/TextEditor/TextEditor.xcodeproj

The build command now generates 63 errors.

Any ideas on what I did wrong? It seems that the OmniUI frameworks did not get built, but I don't see what needs to be changed... I did a './Scripts/Build Frameworks/OmniUI' to see if that would help, but I still don't find any place where 'OmniUI/OUISingle*' is installed anywhere... It only exists in the source tree, but with iPad in the path (OmniUI/iPad/OUISingle*)



Charlie
Attached Thumbnails
Click image for larger version

Name:	TextEditor-build-errors.png
Views:	391
Size:	184.9 KB
ID:	1652  

Last edited by cwoloszynski; 2010-10-22 at 06:05 PM..
 
Ah, found another post that helped.

Needed to build OmniUI separately.

In doing that, had to change a deprecated method (directoryContentsAtPath:) --> (contentsOfDirectoryAtPath:error:)

Then, it all works and I see it running in the Simulator!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling OBLoadBundle on master carllerche Omni Frameworks 4 2010-05-13 09:56 AM
Beta 8 is available Lizard OmniPlan General 6 2006-10-20 08:53 AM
Beta 7 smhaunch OmniPlan General 1 2006-09-21 08:13 AM
beta 6 expires on September 13th -- get beta 6b smhaunch OmniPlan General 1 2006-09-12 12:39 PM


All times are GMT -8. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.