The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Export to Web Page (beta 7) Thread Tools Search this Thread Display Modes
Looks like the behavior of Export -> Web Page has changed in beta 7. OmniPlan now saves the resulting directory as "blah.htmld", and I can't find a way around it. If I remove .htmld from the save dialog, it automatically enables "hide extension"; disable "hide extension" and it re-adds .htmld.

My only way around is to save it as blah.htmld, then force a rename through Terminal window to remove the .htmld, at which point Finder recognizes it as a normal folder.
 
I think we did this to work around the more troublesome behavior of having the web page export keep the extension of whatever you'd previously selected, causing a lot of people to accidentally save right over their original OmniPlan files.
 
Quote:
Originally Posted by kaan
Looks like the behavior of Export -> Web Page has changed in beta 7. OmniPlan now saves the resulting directory as "blah.htmld", and I can't find a way around it. If I remove .htmld from the save dialog, it automatically enables "hide extension"; disable "hide extension" and it re-adds .htmld.
The NSSavePanel doesn't really support exporting to a filename without extension. If you configure an exportable file type without an extension, it has fairly unpredictable effects, the most common one being that, by default, it will pick MyDocument.omniplan and overwrite your plan with your export without warning.

There's probably some magical incantation that we could put in the code to make this work better... I don't know what it is, but I messed around with it for more time than I could afford. Besides, what we're creating is a .htmld file wrapper - it's an old standard with a long and glorious tradition. Why not use it?

Quote:
Originally Posted by kaan
My only way around is to save it as blah.htmld, then force a rename through Terminal window to remove the .htmld, at which point Finder recognizes it as a normal folder.
If you export and click the expansion triangle next to the filename, you can opt not to hide the extension. This setting is persisted and defaults to true system-wide. If true, it will set the same flag on the file controlled by Finder's inspectors under "Name & Extension". If you turn it off, do you get something more like what you want?

It kind sounds like you have some software installed that recognizes .htmld directory wrappers and treats them as packages. Seems like if you do, the behavior you have is what you might want.

The part that I find suspect is that I specify to save the directory as a package. In this case, I think it may be inappropriate, but I need to find out why Finder is treating .htmld as a package for you and not me in order to be sure. If you right-click the directory do you get an "Open With" menu? What's in it?

-Tom

Last edited by Tom Bunch; 2006-09-29 at 11:54 AM..
 
Tom,

Your comments suggest that there's something strange going on with my computer. That may well be the case, but to my knowledge, I don't have any additional software installed, and I'm not into little hacky extensions and stuff. I'm stumped. Regardless, I definitely appreciate the effort you guys are putting into this. So, thanks. :)

This started because I am unable to do anything with the .htmld output. I really don't care what the extension is, as long as it's usable. If I get info in Finder, it shows an empty white page for icon, "Kind: Web Page". Right-clicking the file shows "Open with" defaulted to "<None>" (which is grayed out) along with a single choice of "Other..." (this one is not grayed out).

I repeated the same steps and took notes this time; here's what happened. I have a project named "1.2 - Beck". After choosing Export to Web Page, the default name in the Save As box was "1.2 - Beck.htmld". The "Hide Extension" checkbox was not checked. I deleted the ".htmld" portion of the suggested save name, and the "hide extension" checkbox instantly checked itself. When I unchecked the box, the suggested name instantly reverted back to "1.2 - Beck.htmld". Also, this behavior only started with beta 7; beta 6 worked fine. Hope this helps.

So, what's the default Finder behavior supposed to be for .htmld?

Kaan
 
Quote:
Originally Posted by kaan
So, what's the default Finder behavior supposed to be for .htmld?
Hi, Kaan.

Don't mean to blame the victim here. I mentioned in my post that I have a little flag set to say that these .htmld directories are packages... my understanding is that this should have no effect, since OmniPlan doesn't actually have any role for .htmld directories. That is, it is neither an editor nor a view for them. I'm trying to figure out why on your system .htmld _is_ a package, and on mine, it's a simple directory. The fact that your "Open with" menu is empty just proves to me that I don't understand the issue. Curses! I'll keep sniffing about. We've had a couple other users report similar issues, so you're not alone.

-Tom
 
Tom,

I have to side with Kaan on this one. I just tried the export to Web Page option and I too get the generic white icon associated with the resulting htmld file. When I choose Open With... Other, I am unable to browse to Safari or Firefox as applications that are capable of reading the file. They are both grayed out.

The workaround is simple, but kind of a pain. Just get info on the file and change the extension from htmld to html in the Name & Extension box, click return and you're all set.

This was the case on two different machines here at our office, so there does seem to be an issue with the htmld extension.

Testing out the app now and I'm liking what I see. Keep up the good work!
 
I appreciate the reasons behind the htmld extension, but it isn't the most intuitive. Also, the same issue exists other Omni products export to web, where an extension is always added. In this case, launch services becomes aware that htmld is supposed to be a package, causing the strange behavior. In other products, an undesired extension is added to the name, but it doesn't say to Launch Services that it is a package in Info.plist.

For those having issues, there are two workarounds in OmniPlan Beta 7:

A) In the finder, select the htmld "file", choose Get Info, remove the .htmld from the name, tab out of the form & close Get info. The Finder should now see it as a folder.

B) In the finder, ctrl-click or right click on the htmld file. Choose Show Package Contents. This opens a new window inside the "folder". Copy the contents to your desired directory.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Scaling project to print on one page crashes beta darwin OmniPlan General 4 2007-11-16 12:41 PM
export to web page? rod OmniFocus 1 for Mac 4 2007-10-15 04:23 PM
BETA 8 bugs: Export to HTML Web-page aleding OmniPlan General 9 2007-06-18 02:45 PM
Export to Web Page aleding OmniPlan General 2 2006-10-19 05:36 PM
Error loading Boot Camp Beta Thank You page j.a.duke OmniWeb Bug Reports 0 2006-04-05 06:50 AM


All times are GMT -8. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.