The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

The document could not be saved Thread Tools Search this Thread Display Modes
New user.

I like Omnifocus, been using it for a while. I require something more flexible to keep track of ideas and thoughts that just are not tasks, but a cloud of things which have no immediate flow to them. Heck, a journal is an example of something I'd like to keep in here.

Anyways, I have to say my first experience with Outliner is a bit disappointing.

Opened up the application for the first time.
1) renamed the root of the untitled document is loaded by default to: "Journal"
2) recorded an entry under the first topic and gave it some text.
3) attempted to play back the recording by clicking on the recorded item. Received error that it must be saved first. Huh? Why should I save something if I don't even know if I like what I said.
4) fine, so I save. Choose a file name. And receive the error: The document could not be saved.
5) Tried save-as. Same problem
6) After a few minutes I get the lovely error again, but this time "The document untitled could not be saved.

You know, when you encounter a bug like this while trying to do the very first thing, it is really a crushing feeling: "oh shit, did I just spend 60$ on a piece of bugware"?

I am disappointed.
Hi, sorry for the trouble you experienced! Are you possibly saving your file to a Windows share? That could explain part of this. Also, it sounds like the second time you saw the error it was due to the auto-backup failing possibly due to a permissions error? in Applications/Utilities might shed more light on this error.

Please email support at if you haven't found any obvious reason for this answer and we'll help you get to the bottom of it.
Derek, I remember getting the "need to save before playback" message in the past, but don't seem to get it any longer. What are the circumstances under which I should see that, if any?

jrpetit, I've been using OmniOutliner since the middle of 2002. You didn't buy a piece of bugware! However, if you feel otherwise, check out Omni's refund policy on their store web page if you're still within 30 days of the purchase date.
I don't know what would cause that. But I wonder if perhaps jrpetit, and maybe you when you saw it, was double-clicking on the recording, or clicking on the on the option to open it in the native app. In this case it will act just like any other embedded attachment and you will need to save first so it's actually in the file wrapper.
Ah, yeah, that's it -- clicking on the little QuickTime icon gets that response. Apparently I'd trained myself to open the row and click the play button, where saving isn't necessary.
Additional information:

- I am not saving it to a file share.

Here is what I am now doing to reproduce this problem:
(I tried saving the document first before recording the audio this time)

1) Create a new document
2) Create a new entry
3) Record audio for that entry.
4) Hover on the entry with the mouse, then you will see a little arrow on the right.
5) Click on the arrow.
6) The error appears every time.
7) After this error appears, it is impossible to save the document.

Last edited by jrpetit; 2009-10-07 at 12:38 PM..
You're clicking on the arrow on the right correct? That arrow will appear for any attachment and means "open this in the default app for this file type". What you want to do is click on the left arrow which will then expand the attachment so you see the the audio playback bar and you can play it back from there.

However.. doing what you are should not stop the file from being savable...
Are you able to save files without an audio recording in it?
Edited out my name.
09-10-07 11:20:50 AM OmniOutliner Professional[30580] This version of OmniOutliner has a newer Spotlight importer (/Applications/OmniOutliner, version 3) than previously run ((null)). Requesting a re-index of files handled by our importer.
09-10-07 11:20:50 AM OmniOutliner Professional[30580] *** WARNING: Method selectedRowEnumerator in class OSActionValidatingTableView is deprecated. It will be removed in a future release and should no longer be used.

09-10-07 4:23:16 PM OmniOutliner Professional[30580] (null): file manager error: {
Error = "Error removing";
Path = "/Users/##/Desktop/OmniOutliner Audio Recording Temporary";
09-10-07 4:25:44 PM OmniOutliner Professional[30580] *** WARNING: Method selectRow:byExtendingSelection: in class OSActionValidatingTableView is deprecated. It will be removed in a future release and should no longer be used.
09-10-07 4:27:36 PM OmniOutliner Professional[30580] (null): file manager error: {
Error = "Error removing";
Path = "/Users/##Desktop/OmniOutliner Audio Recording Temporary";
Finally, if I delete the audio, it is now possible to save the document.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
The document x.oo3 could not be saved. caek OmniOutliner 3 for Mac 4 2010-09-12 11:47 PM
The document "x" could not be saved as "x" Melan OmniOutliner 3 for Mac 3 2009-03-09 10:42 AM
"Unable to lock document. Another application had the OmniFocus document locked." drumshanbo OmniFocus 1 for Mac 7 2008-09-18 09:31 AM
OmniGraffle Pro 5.0 document cannot be saved peternies OmniGraffle General 0 2008-05-19 12:33 PM
Custom Colors not saved in document cityspacer OmniGraffle General 0 2007-10-05 09:17 AM

All times are GMT -8. The time now is 04:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.