The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

OF iPhone HTML Export Script Thread Tools Search this Thread Display Modes
Originally Posted by billdill View Post
I may have ruined my ruby installation. In terminal I ran the command:

Ruby -v

and it returned a version number. But it still would not install the applescript Gem.

Then, as suggested above I ran the commands:

sudo mv /usr/bin/ruby /usr/bin/ruby~
sudo ln -nfs /opt/local/bin/ruby /usr/bin/ruby

Now when I run the version command I get:

ruby: command not found.

I'm a complete novice at this kind of hacking. Can anyone please help restore my ruby install? I already have the developer tools installed.

Thank you in advance for your help.
The command will only work if you installed ruby using MacPorts. If you're on Tiger you need to do this (update your Ruby installation, there are planty of guides how to do it, just google it). To make your ruby work again, just rename your backup copy back:

sudo mv /usr/bin/ruby~ /usr/bin/ruby

and it should work again.
Thank you for your assistance. I'm sorry that I wasn't more specific. I'm using Leopard.

I tried the command and I got the message:

mv: rename /usr/bin/ruby~ to /usr/bin/ruby: No such file or directory

The odd thing, when I drill down and type the ls command in the /usr/bin directory I can see ruby listed there. I don't understand that.

Thanks for your help,


Last edited by billdill; 2008-01-05 at 05:35 AM..
Thank you Martin! With much trepidation, since I really don't know what I'm doing in terminal but have been very frustrated not being able to access OF on the iPhone, I installed the Xcode, ran the sudo commands, didn't blow up anything, ran your script, and there it is! Lovely magic.


Last edited by Gretchen; 2008-01-06 at 08:09 PM..
Okay, I finally got this working!

Am I correct to say that if a project is sequential the script will not pull any task beyond the "next action"? That is the way it is working on my machine at least.

Why would you not want all the tasks for a sequential project on your iPhone when you are on the go? I need the entire project listed sequentially!

Do I have something working oddly with my script?
Is there a "quick fix" to have the script pull all tasks instead of the first sequential task?

Thanks geniuses!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
.html extension on dynamic html export pairustwo OmniOutliner 3 for Mac 3 2011-09-10 02:53 PM
script to export OOO to html and place on iDisk rhythmone OmniOutliner 3 for Mac 1 2008-08-27 07:32 AM
Export to HTML - What am I doing wrong? lsamberg OmniPlan General 3 2008-05-21 07:15 AM
OF iPhone HTML Export Script wkoffel OmniFocus 1 for Mac 0 2007-10-11 09:22 PM

All times are GMT -8. The time now is 11:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.