The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Sync: server returned an error 403 "forbidden" Thread Tools Search this Thread Display Modes
I submitted this a while back and got a response from the tech guys to send in some diagnostics, but I'm still not able to sync to my iPhone. Using an updated MacbookPro and my .Mac (now .me) account. I sync to my iDisk and successfully send the settings to my iPhone. When I tap on my name to start the sync, I get the following message:

Unable to perform WebDAV operation. The server returned an error 403, "forbidden"

Is anyone else getting this message?

The very first time I did this last week, it asked for a password. Is it possible I entered the wrong password (for my iDisk access?), and it doesn't ask me again for a password?

Looking for any help here to get this working with my iDisk and iPhone.
 
Yes, I have been getting this error message since getting the OF iPhone app. Tech support sent a automated case number for my inquiry but so far I haven't heard anything. Sync to the iDisk seems OK so I'm assuming the desktop OF app is accessing my idisk (the file is where it should be but, I have no way to actually read it).
 
Can you check if there's a more detailed error message in Console?
 
This error happens when the password is wrong or there is no password entered. It is a permissions error. This happened to me when for some reason OmniFocus on the iPhone never gave me the screen to enter my password for my iDisk! This is a huge bug that needs fixed. We really do need a credential screen that we can go to, because it does not always go there automatically
 
403 "forbidden" indicates that you've authenticated successfully, but run into some other problem such as attempting to list the contents of a directory that you don't have access to. With the transition from .Mac to MobileMe, we've found that it sometimes helps to change your sync URL from mac.com to me.com. Go to "iDisk" (or "Advanced", in more recent builds) and enter the url "https://idisk.me.com/USERNAME/Documents/", replacing USERNAME with your own MobileMe username.

Another possibility is that the username and password you've entered are valid, but don't have permissions to access the folder for the username you've entered under your iDisk synchronization settings. In this case the iDisk server won't send the usual 401 "unauthorized" error that causes OmniFocus to prompt for new credentials, it just sends 403 "forbidden". I'll file a bug that we should prompt for updated credentials in that case, rather than just returning the error and offering to retry. (And I agree that there should be some mechanism for manually resetting credentials.) In the meantime, if the above workaround of switching to idisk.me.com didn't help, I can think of two options: you could temporarily change your iDisk password so OmniFocus gets a 401 and prompts for new credentials, or you could uninstall OmniFocus from the iPhone altogether (resetting its saved credentials) and reinstall it.
 
I have changed the password of my iDisk - but it didn't work. So I uninstall (i.e. delete) OF on my iPhone and reinstall it - still does not work. OF on my iMac (at work) syncs to iDisk and then onto my Mac Book Pro (at home), but OF on my iPhone just will not sync and I keep getting "The idisk.me.com server returned "forbidden" (403)......etc".

Incidentally I have created a new mobile me account but OF on iPhone never prompt me to enter any credentials.

What should I do?
 
Try the workaround Brian suggested here:
http://forums.omnigroup.com/showthread.php?p=44200
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? giessler iDisk/MobileMe/.Mac Syncing 19 2011-06-21 08:33 PM
Filenames w/chars like "ä" cause error exporting to O. Sync Server. [Bug; will fix.] devastat OmniOutliner for iPad 5 2011-05-12 12:03 PM
Omni Sync Server returned "forbidden" 403? [Resolved by resetting keychain] Philcollins1000 OmniFocus Syncing 4 2010-12-19 08:26 AM
"Server returned "redirected" (330)" error jasong OmniFocus 1 for Mac 3 2010-09-29 10:02 AM
Unable to Sync - Error 403 "forbidden" fishwind OmniFocus Syncing 2 2008-07-17 02:10 AM


All times are GMT -8. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.