The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Nasty Case of Thick Developer: Can't Compile iPad Examples! Thread Tools Search this Thread Display Modes
Hi All,

I'm a very experienced developer, but relatively new to XCode (have built and released a few Apps, but all with our own code so I've not tried to integrate a range of different "sources" before).

I'm just trying out the OmniUI iPad example in Examples/TextEditor. It seems that I've not correctly configured the project to find the headers on my machine. I've tried adding the Frameworks directory with Recursive ticked for user headers (I assume that doesn't work as the includes are wrapped in <>) and also the standard header search paths. No joy.

I'm certain I'm doing something dumb... but any pointers?

Did you set up the necessary Xcode preferences for a customized build output directory (see the README on <>)?
CTO, The Omni Group
Originally Posted by Tim Wood View Post
Did you set up the necessary Xcode preferences for a customized build output directory (see the README on <>)?
Hi Tim,

I did the customized build output directory setting by choosing to place build products in customized location: /Users/Shared/philip/Products

And Place Intermediate Build Files in: "With build products"

I also successfully built the Debug & Release versions.

However, when I run TextEditor.xcodeproj and go "Build & Run" I get "OmniUI/OUISingleDocumentAppController.h No such file or directory" and so on up to 63 errors.

Seems like I'm missing a very basic thing here.
Hi -

TextEditor pretty much runs out of the box if you follow Tim's direction above. You may have inadvertently obliterated some header search path setting while touching the frameworks paths. Xcode can get pretty nasty that way, that's why xconfig files are the way to go and in Omni's case there are a boat load of them in the Configurations Group. Look at Touch-Application-Common, it contains your targets relevant settings and the all important HEADER_SEARCH_PATHS. Remember that you can easily and inadvertently "overide" these settings with manual entries even though the "Based On" menu at the bottom of your Target Info panels is set correctly. You can usually tell if the setting is in bold. If you can no longer sort out what you changed, start from a clean copy and carefully compare between the two.

Strange that you are only getting that single header file error though...Are all the other OmniUI headers loading correctly?

Found this post searching the web for the error message...

Got the same issue philip has, same error number, same missing headers.
all code out of github unaltered, and build products in correct location...

But found the solution...
OmniUI wasn't built, just opened it and builded it with XCode, and voilą! :)
OmniUITouch is just missing as a direct dependency in TextEditor project.

Never seen such build configuration, complex, but interesting :)

offtopic, CopyLibraryResources script doesn't like ruby 1.9 ;)
Thanks! I've no idea how that dependency went missing, but I've pushed a patch with it re-added.

As far as ruby 1.9, we haven't even tried it. We've having plenty of fun trying to keep up with Mac OS X, Xcode and iOS betas. I suppose 1.9 is getting stable enough we should try it, but until it is installed on the system by default we won't be requiring it.
CTO, The Omni Group

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for iPad developer to customize Omni's RTF texteditor. appapps Omni Frameworks 0 2011-01-18 10:13 AM

All times are GMT -8. The time now is 05:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.