The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > iDisk/MobileMe/.Mac Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Keychain problem causes "too many open files" error Thread Tools Search this Thread Display Modes
Hello,

My desktop OF has not synced with MobileMe for about 30 hours. The orange sync icon continues to turn with an exclamation point in the center of the two turning arrows. I had trouble getting this to work in the past and I just changed the OmniFocus.ofocus to old_OmniFocus.ofocus (thanks to a suggestion on this forum). But unfortunately it didn't help this time.

I also did a reset of the Syncing properties and then did another sync. I saw that it created another OmniFocus.ofocus sync file on iDisk, but the OF Sync properties menu said that the sync failed.

Any suggestions would be greatly appreciated.

I am syncing via Bonjour in the meantime.

Thanks,
Adam

Last edited by zakuska; 2008-12-28 at 04:57 PM..
 
Quote:
Originally Posted by zakuska View Post
Hello,

My desktop OF has not synced with MobileMe for about 30 hours. The orange sync icon continues to turn with an exclamation point in the center of the two turning arrows. I had trouble getting this to work in the past and I just changed the OmniFocus.ofocus to old_OmniFocus.ofocus (thanks to a suggestion on this forum). It didn't help this time.

Any suggestions would be greatly appreciated?

Thanks,
Adam
Click on the exclamation point to pop up an error notification describing what went wrong.
 
Quote:
Originally Posted by whpalmer4 View Post
Click on the exclamation point to pop up an error notification describing what went wrong.
I clicked on the exclamation point and it showed me a dialogue box with the message:

Unable to synchronize database with server.
Operation could not be completed. Too many open files


Is this saying I have to many items in my OF program?
 
I found another post on the OmniGroup forum that is probably related to this.

http://forums.omnigroup.com/showthread.php?t=9973

In this thread, one of the members posted this information that is from the Troubleshooting Common Issues page.

http://www.omnigroup.com/application...oubleshooting/

Quote:
If your database is too big, it will be too large to fit in the iPhone's memory. If you are also using OmniFocus on a Macintosh (the most likely way to encounter this problem), consider archiving some of your data by choosing "Move Old Data to Archive" from the File menu. In general, we recommend trying to keep the number of actions on your phone down below a thousand.
I have 722 actions, so this could be the problem. I don't have 1,000 actions, but I'm thinking that I have copied some larger files into the comments fields.

I will see if I can pare this down. I have been using OF also as a list manager since nothing like OmniOutliner is available yet.

I really appreciate your help. I will check back to see if there are any more suggestions.

Adam
 
I just found out that I have TWO databases. I have OmniFocusDatabase and OmniFocusDatabase2. The second database was created about an hour after the last sync with MobileMe, Saturday at 8:19am. Since then I have not been able to sync.

I found the two databases at my HomeFolder/Library/Caches/com.omnigroup.OmniFocus

Would it just try to sync with the last created database? Am I supposed to delete one?

I appreciate any insight anyone can give.

Adam
 
The OmniFocusDatabase2 in the Cache directory is a cache of your data for faster access. It will be replaced if you use the File->Rebuild Database command.
 
Quote:
Originally Posted by zakuska View Post
I clicked on the exclamation point and it showed me a dialogue box with the message:

Unable to synchronize database with server.
Operation could not be completed. Too many open files


Is this saying I have to many items in my OF program?
No, this is a message from the operating system stating that you've got too many files open and no more can be opened (which is a problem when you go to sync, as the network access is done through a file access). Use Keychain Access to see if you might have multiple entries for me.com, as seen here.
 
Quote:
Originally Posted by whpalmer4 View Post
No, this is a message from the operating system stating that you've got too many files open and no more can be opened (which is a problem when you go to sync, as the network access is done through a file access). Use Keychain Access to see if you might have multiple entries for me.com, as seen here.
I'm looking in my Keychain under "All Items" and I only see one thing that says "idisk.me.com (emailname@mac.com). That is under "Name." It says it's an "Internet Password" under the heading "Kind", and it's a "login" under the heading "Keychain".

And now I've really messed things up because my OF application won't display anymore after I must have made an error in trying to figure out this syncing issue. But that's now on a different thread.

But it looks like I only have one entry for me.com.
 
The smooshing script has done wonders for me.

My syncing slows down after about a month of use. Running the smooshing script dramatically improves the syncing. From sync times of 5 to 10 minutes down to under a minute.

http://forums.omnigroup.com/showpost...87&postcount=1
 
Too Many Open Files can be caused by any number of problems, but assuming that it's a sporadic or one-time thing, rebooting should recover.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
NOT APPLICABLE TO OMNIFOCUS 2: What to do about "Unable to open zip archive" error? timomni OmniFocus 1 for Mac 14 2013-10-02 04:51 AM
Import error: OmniGraffle Pro cannot open files in the "XML text" format MCV OmniGraffle General 5 2012-08-31 10:43 AM
What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? giessler iDisk/MobileMe/.Mac Syncing 19 2011-06-21 07:33 PM
Omni Sync Server returned "forbidden" 403? [Resolved by resetting keychain] Philcollins1000 OmniFocus Syncing 4 2010-12-19 07:26 AM
"Server returned "redirected" (330)" error jasong OmniFocus 1 for Mac 3 2010-09-29 09:02 AM


All times are GMT -8. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.