The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Mail Clipping Trouble after updating OS X? Start Here! [esp. 10.6 or later] Thread Tools Search this Thread Display Modes
Several changes that Apple's made in the 10.6 (and subsequent releases) of OS X are affecting folks that use OmniFocus' Clipping feature.

This sticky thread will contain descriptions of the various problems that folks are seeing, and what steps to take to correct each of them. In order to keep things easy to read for new visitors, the thread will be locked, but feel free to discuss and link back to posts here in other threads.

Last edited by Brian; 2010-06-25 at 04:12 PM..
Starting in 10.6, will refuse to use plugins that don't specifically state that they work with the version of Mail that's installed on your machine.

In short, every maintenance release of Mail now means that you'll need to download a new version of OmniFocus on each of your Macs and install the Clip-o-tron from that updated release.

You'll know you need to do this when you'll see a message that reads "OmniMailMessageEnabler could not be verified".

If you've seen that message, please head over to the OmniFocus page. Download the most recent build you find there, then do the following:
  1. Quit (but do not delete!) any running copies of OmniFocus on your Mac.
  2. Quit Mail.
  3. Double-click the .dmg file you downloaded.
  4. Locate and open the squarish white icon on your desktop named "OmniFocus".
  5. Launch the copy of OmniFocus you find on the mounted disk image.
  6. Open Clipping Preferences and press the button in the bottom right to install the clip-o-tron.
  7. Quit the running copy of OmniFocus. Drag the square white icon to the trash.
  8. Launch Mail and your previous copy of OmniFocus. You should no longer recieve the error message you were getting before.
    To test that the clipping shortcut has been properly installed, select some text in Mail, then Control- (or Right-) click the selection.
    If "Send to OmniFocus" appears at the bottom of the context menu, the update succeeded.

Note: If you're still unable to clip via the keyboard shortcut, it's likely that you were encountering this problem as well as one of the others on this page. Keep reading!

Last edited by Brian; 2009-11-15 at 02:33 PM.. Reason: remove link to sneakypeek page, as it's no longer necessary.
Mac OS 10.6 also took the step of disabling any keyboard shortcuts assigned to your services. You'll need to re-enable the service shortcut using System Preferences.
Note: Apple added several new default keyboard shortcuts for services offered by their applications in 10.6 - if your previous shortcut conflicts with one of Apple's, you will need to choose a different one.

It also appears that Apple will no longer allow you to use any of the Function keys as the shortcut for a service; you can't, for example assign F19 to one of the services that OmniFocus (or iChat, for that matter) offers. You can, however, use a function key along with the command key.

Personally, I use command-F6 for my clipping shortcut. (Folks on MacBooks or MacBook Pros may need to use the "Fn" key to access the function keys; a lot of Apple's keyboards - particularly on laptops - have their own built-in uses for those keys.)

If you were previously using one of the troublesome keys in your OmniFocus clipping shortcut, you'll need to find a new keyboard combo to use. Ken finds that Shift-Command-Comma works well as a clipping shortcut for him.
To re-enable your keyboard shortcut, do the following:
  1. Open System Preferences from the Apple menu.
  2. Select the "Keyboard" pane, and switch to the "Keyboard Shortcuts" tab.
  3. Select "Services" in the list on the left. (Next to the icon that looks like a gear.)
  4. With "Services" still selected, scroll the right hand pane until you see the "Text" grouping.
    (There's a bug in 10.6.x which can cause this pane to be blank; see the next post for what to do.)
  5. Continue scrolling in the Text group until you see the "OmniFocus: Send To Inbox" entry.
  6. If the box to the left of "OmniFocus: send to inbox" isn't checked, check it. You should see a keyboard shortcut specified in this line which matches the one you chose in OmniFocus' preferences. If you don't see a shortcut here, quit System Preferences and return to OmniFocus' preferences. Clear out the shortcut and reassign it, then check System Preferences again. If you still don't see a shortcut in System Preferences, please try double-clicking at the right end of OmniFocus' line in the list, then type the shortcut you'd like to use directly into the list.

    If that doesn't work either, please contact the support ninjas so we can help.

Important Note: Unlike the 10.4 and 10.5 releases of Mac OS X, 10.6 releases will only automatically associate a custom keyboard shortcut with a service if it includes the Command key. If a shortcut omits that key, customers need to open the Service menu and make OmniFocus' entry visible before the shortcut will work. (And if you restart the app in question, you'll have to repeat this process.)

In the early days of OS 10.6, we got a lot of email from folks that were unaware of this change in the OS and whose keyboard shortcuts weren't working the way they expected. Rather then let this continue indefinitely, we changed OmniFocus so it required that key as part of the clipping shortcut.

This has the drawback of requiring some customers to choose and learn new shortcuts, but once they do so, it should work consistently and predictably. We hope that's an improvement over the previous situation, where sometimes it would work and sometimes it wouldn't.

Last edited by Brian; 2011-03-10 at 10:30 AM.. Reason: add info on typing shortcut directly into System Prefs
Some customers are reporting that the right-hand pane of their Keyboard Shortcuts preferences are blank after upgrading to Snow Leopard. Thus, there are no boxes to check to re-enable the clipping shortcut. Basically, it looks like this:

One of the first customers having this problem took his machine to the Genius Bar at his local Apple store and was able to resolve this problem with his Snow Leopard installation. For the steps they used to fix the problem, look here.

Last edited by Brian; 2009-09-18 at 01:30 PM..
If you've tried all the other tips here and are still having trouble, the first thing to do is try rebooting the application you're having trouble clipping from, then try again.

If that doesn't solve the issue, the next important thing to check and make sure the menu item for the OmniFocus clipping service is showing, and has your keyboard shortcut next to it.

To test this, select some text in the application you're having trouble clipping from, then choose
<name of the application> -> Services
from the menu bar.

If no submenu appears when you hover over the Services menu item, this application may not support the Services system at all. Firefox and Microsoft Office are examples of applications in this category. You'll want to email the developers and ask them to add Services support. (You may still be able to clip in other applications, of course.)

If a submenu appears, but you don't see an OmniFocus: Send to Inbox entry, you'll want to double-check these steps to make sure that the clipping service hasn't been turned off accidentally.

If a submenu and the OmniFocus entry both appear, but you don't see a keyboard shortcut in the menu item, then you'll want to check OmniFocus' clipping preferences pane. It's possible that the shortcut got disabled. (If the "reset" button in the clipping shortcut field was pressed, for example, or if the Reset button at the bottom was pressed.)

If a submenu appears, you see the OmniFocus entry, and it has a shortcut, the clipping service is set up correctly. Our code has registered the shortcut with the system and is ready to accept events that Mac OS X sends along.

If the shortcut still isn't working, that means we're not receiving those events for some reason. Keep reading for steps to use to figure out why the messages aren't making it to the service.

First, try the shortcut in several different applications; if it works in some of your applications, that means the other applications are using the shortcut you chose for their own purposes. You'll want to try a different shortcut that doesn't conflict with theirs.

If the shortcut never succeeds, the next thing to check is for a conflict with one of the other keyboard shortcuts enabled on your Mac. Open up Keyboard preferences and disable all the shortcuts by unchecking their boxes in the preference pane.

Everything from "Dashboard & Dock" to "Application Shortcuts" in the left-hand list needs to be selected, and everything in each of the sub-lists on the right must then be unchecked. Once that's done, re-check the box next to the OmniFocus service - it's in the "Text" subsection of the "Services" group.

Finally, re-start the application you're trying to clip from and try the shortcut again. Does it work? If so, you can re-enable the shortcuts you want to use on your Mac in System Preferences.

If you've tried all this and are still having trouble, please contact the support ninjas. Let them know what shortcuts you've tried, which apps (if any) they work in, and what version of the OS is installed on your Mac.

Last edited by Brian; 2010-01-26 at 02:28 PM.. Reason: add firefox/office info

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail clipping: no attachments in Lion [A: caused by change to in 10.7] lgallerano OmniFocus 1 for Mac 36 2014-02-20 04:04 PM
Trouble clipping from Firefox [Use bookmarklet] sooinlee1 OmniFocus 1 for Mac 12 2011-06-25 04:31 PM
Trouble clipping some emails [A: actually, view settings were hiding some actions] bister OmniFocus 1 for Mac 3 2010-01-07 01:18 PM
Mail Clipping Tool Breaks with Mac Mail 4.0 thelegacylady OmniFocus 1 for Mac 1 2009-12-01 04:35 PM
Mail Clipping trouble after updating Tinchohs OmniFocus 1 for Mac 2 2009-09-22 06:54 AM

All times are GMT -8. The time now is 07:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.