The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
xcode4 archive failed Thread Tools Search this Thread Display Modes
I try to archive the TextEdit sample for a ad hoc and a release version using Xcode4.3 .
The steps should be right as I uploaded the app to the App Store before.
When I make a ad hoc version, it has error:

FixStringsFile not found at /Users/****/Library/Developer/Xcode/DerivedData/TextEditor-ahfhqeyklfvqoccinvgjozxdcpst/ArchiveIntermediates/TextEditor/BuildProductsPath/Ad Hoc/FixStringsFile! (RuntimeError)

And for the release version, no error happened after the archive. But there is nothing in the Organize-Archive.

I really need your framework and don't know how to fix it.

Could you help me?
Thanks!

PS: My app is for ios5 and can't use xcode3.
 
FixStringsFile is a Mac OS X command line tool that we use to sort, validate and perform some other transformations on localizable strings files. This gets run from some of the shell script build phases (via Scripts/CopyLibraryResources and Scripts/BuildStringsFromTarget).

The answer may be as simple as editing your scheme to build FixStringsFile before the Omni framework library targets. But, since we don't currently package our build products from within Xcode (we have a bunch of command line shell scripts that package and sign build products), I don't have an sure fire answer for you.
__________________
CTO, The Omni Group
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
build commands failed for OUUnzipArchive.* global667 Omni Frameworks 2 2012-11-20 07:11 AM
Xcode4 and release build tnys Omni Frameworks 3 2011-08-23 11:44 AM
Build failed John.Boydon Omni Frameworks 1 2009-02-28 02:01 PM
MobileMe Sync Failed - any advice? jka33331 iDisk/MobileMe/.Mac Syncing 10 2008-07-31 07:13 PM
SP7 failed with Hotmail dru OmniWeb Bug Reports 1 2006-05-04 05:45 PM


All times are GMT -8. The time now is 12:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.