The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Items don't show in a view where they should Thread Tools Search this Thread Display Modes
Regularly, OF does not show me items when I think it should. E.g. in the Context view, it says for a context "1 available, 1 overdue" but when I select that context it shows no items.

See these screenshots:



This is now the context "SWi" selected:



Is this a bug?

Another strange situation:

None is available, but ONE is overdue.



Selecting this context shows an EMPTY list!


These are my settings, in case that matters:



Am I expecting the wrong thing or is this a bug?
 
This will happen if you have a sequential project with tasks that are due, or overdue, and those tasks are blocked because there is another task in the project that needs to be completed first. If you change the context setting to Übrig, the due/overdue tasks will display.
 
Quote:
Originally Posted by Greg Jones View Post
This will happen if you have a sequential project with tasks that are due, or overdue, and those tasks are blocked because there is another task in the project that needs to be completed first. If you change the context setting to Übrig, the due/overdue tasks will display.
Those projects are NOT sequential.

And I don't want to change the setting to "remaining" because that brings on many items to many different views that I want to keep clean.
 
We'd probably want to take a look at your database to know exactly what's going on, I can give a couple of examples that may look like this:

A project or action has a due date in your "soon" window, but a start date that hasn't arrived yet. Example: an action is due tomorrow at 5pm, but the project has a start date of tomorrow at 9am.

We have a feature request open for detecting cases where the due date is before the start date, but we haven't been able to add that yet. If your action is in that state, that could cause the overdue one you're seeing.

Make sure to check both the action, the project, and any action groups that may be involved: OmniFocus looks all the way back to the root of the project structure and uses the earliest date it can find for those badges.

If those don't help you sort out what's going on here, zip up your database and send it as an attachment to the support ninjas; we can figure out what's going on here.

Side note - if you press the Power and Home buttons on your iPod or iPhone simultaneously, the screen will flash white and a screenshot will be added to your photo roll. It's handy if you want to capture a screenshot with no external camera handy.

Last edited by Brian; 2009-03-20 at 03:28 PM.. Reason: why do I never notice typoes until I've posted?
 
As you can see from the photo attached, I got the same problem - not on the iPhone, but on OF 1.6, and also with the German version: "Kein Kontext" (no context) says there are two items, but the list is empty, though the filter is set to all items left.


Frank
Attached Thumbnails
Click image for larger version

Name:	NoContext2Items.jpg
Views:	248
Size:	19.1 KB
ID:	892  
 
I just registered to post about the same problem, and i resolved it by reordering my tasks - In the project containing the item that wasn't appearing in proper context view, there was an over due item blocking it. Since the project is NOT listed as sequential, but rather parallel, shouldn't this be viewed as a bug? IE just because one action is overdue, I should still be able to view other actions.
 
I am seeing similar problems on my iPod Touch. I have two error conditions at present: one where 4 different tasks were overdue and were rescheduled but the red badge icons never went away, and a second where 3 tasks are overdue but the red badge icon does not show up on the Context screen. There are no blocking actions (both sets of tasks come from projects that are parallel, not sequential), no action groups involved, context filter setting does not affect the icons, and all tasks and icons show up correctly on the desktop version. The problems are only on the mobile version: repeated syncing does not change anything, iPod Touch has been hard reset, and I am running the latest versions of both apps. One possible factor (or coincidence) is that both of these sets of tasks involve sub-contexts. One set involves 4 different person sub-contexts under my "People Agendas" context, and the other set involves a meeting sub-context under my "Meeting Agendas" context. Another possible factor that I have noticed is that the red badge icons and their numbers are different on the Context screen versus the individual context screen. Filed as OG #419329.
 
Sorry for the trouble this may be causing!

The folks that are encountering problems like this should zip up their databases and send them to the support ninjas so we can try to determine what's going on here. It would be helpful if you include your forum name somewhere in the email the database is attached to.

The database is stored in
<your home folder>/Library/Application Support/OmniFocus
and is named "OmniFocus.ofocus" or "OmniFocus" depending on the state of your Finder preferences.

(If you're having trouble on the phone and don't use the Mac app, contact the ninjas - there's a different process we can use to get a copy of your data.)

Once we have more data, we can get to the bottom of what folks are seeing.

Last edited by Brian; 2009-03-24 at 02:32 PM.. Reason: add info for phone-only customers, add ninja address.
 
Quote:
Originally Posted by Brian View Post
We have a feature request open for detecting cases where the due date is before the start date, but we haven't been able to add that yet. If your action is in that state, that could cause the overdue one you're seeing.
In my first error condition where 4 overdue tasks were rescheduled but the red badge icons never went away, my start date and time EQUALS my due date and time. This may be the same issue as your feature request, because I removed the start date and time on one of the four tasks, and the red badge icon disappeared immediately.

However, that still does not explain why the "Contexts" screen has a red badge icon with a "1" in it for this context when the screen of the specific context has 4 (now 3) tasks identified as overdue.

I have sent in my database per your request.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Show completed items in flagged view? Nick5a1 OmniFocus for iPad 5 2011-01-21 10:52 PM
How to show completed actions? [A: use View menu ("Eye button") to show All] Patrick923 OmniFocus for iPad 2 2010-08-06 06:10 AM
Top level items lost [A: Groups aren't actions, don't show in context view.] flyklr OmniFocus 1 for Mac 1 2009-10-06 05:09 PM
Show ONLY due items? laughograms OmniFocus 1 for Mac 9 2007-12-01 03:03 PM
Only Show Flagged Items? steve OmniFocus 1 for Mac 14 2007-10-12 08:12 AM


All times are GMT -8. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.