The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Snapping to 1/4, 1/2, or 3/4 of Shape Thread Tools Search this Thread Display Modes
I'm trying to make an integrated circuit symbol, which is essentially a rectangle with pins (horizontal lines) spaced evenly along the sides. I'm placing a magnet on the shape where I want each line to start. Unfortunately, when I get near 1/4 or 3/4 the height of the rectangle, my magnet jumps to some sort of guide, instead of where I'm trying to locate it. I'm sure there's a way to disable this behavior but I don't even know what to search for in the help. How do I turn this off?

Also, can I get magnets to snap to the grid? They seem free form except when I get near certain dimensions of the shape.

Thanks for any help with this!
 
I can't understand why, although I have snap to grid turned on, magnets can be positioned anywhere on a shape, yet if I get near what appears to be a 1/4, 1/2, or 3/4 of the height of the shape, a blue line appears, and the magnet snaps to some position I don't want. This is frustrating in the extreme. Actually, I can't use OG until I can turn this behavior off.
 
Try using Help->Send Feedback or calling Omni @ 1-800-315-OMNI for help. They don't necessarily see forum posts right away -- it's here for users to help each other, not as their primary contact mechanism.

I was able to place magnets exactly where I wanted them along one whole side of a rectangle without incident, and couldn't find any combination of settings that produced the behavior you report. Got the guides at the 1/4 points, but they had no effect on placement.
 
whpalmer,

Thanks. I got a tip from the mailing list to hold command when placing magnets. That overrides any snap to a location for magnets. It worked for me. I was also told magnets cannot (currently) be made to snap to the grid.

Thanks again,

Gary
 
OMNI TEAM - PLEASE make this a feature request. Having magnets snap to the grid is almost a must have and honestly, I cannot believe it's not there yet...
 
Quote:
Originally Posted by GaryTreible View Post
Thanks. I got a tip from the mailing list to hold command when placing magnets. That overrides any snap to a location for magnets. It worked for me. I was also told magnets cannot (currently) be made to snap to the grid.
Glad you got a solution. I wonder what is different about my situation -- I couldn't detect any snap-to behavior of any sort no matter where I placed the magnets. Not an issue, other than I like to understand why :-)
 
Quote:
Originally Posted by aleding View Post
OMNI TEAM - PLEASE make this a feature request. Having magnets snap to the grid is almost a must have and honestly, I cannot believe it's not there yet...
Make it a feature request yourself if you care about it. Use Help->Send Feedback or email omnigraffle@omnigroup.com.
 
Quote:
Originally Posted by whpalmer4 View Post
Make it a feature request yourself if you care about it. Use Help->Send Feedback or email omnigraffle@omnigroup.com.
Already been done but Omni has always asked me to add the feedback here as well. Note the message was directed at them - not you...
 
Quote:
Originally Posted by aleding View Post
Note the message was directed at them - not you...
And mine was intended to help the people who see postings like yours and get the (mistaken) impression that such a posting will actually have an effect on Omni's plans. But you don't have to take my word for it, a little browsing of the forums will find statements from Brian saying the same thing. By all means try to drum up support on the forums, but starting your missive by addressing it to "OMNI TEAM" is likely to mislead your audience, and judging from the number of "me too" and "+1" posts I've seen, there are a lot of posters who don't get it.

Bottom line: if you have a message for Omni and want to make sure they get it, (only) posting it on the forum is not the way to go.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stretching and snapping to object edge jmca OmniGraffle General 0 2011-12-06 05:36 AM
Grid Snapping vs. Smart Guides yawitz OmniGraffle General 8 2011-08-29 05:21 AM
Windows not snapping to size for me. Forrest OmniWeb Bug Reports 4 2009-05-08 01:51 PM
Smart Snapping Gantt Chart partydrone OmniPlan General 4 2006-12-06 03:03 PM


All times are GMT -8. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.