The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Mail's "Show in Mailbox" can't find a filed message Thread Tools Search this Thread Display Modes
Back in the early days (OmniFocus 1.0 on 10.5.1), I posted "Send to Inbox from Mail works ... almost" in a 33-note thread about Mail and OmniFocus.

Unfortunately, the "Show in Mailbox" problem is still with us. Here's the updated scenario:
  1. Select a key sentence in a Mail message.
  2. Use my keyboard shortcut for "Services > OmniFocus: Send to Inbox".
  3. When the Quick Entry appears, select a destination project, and click "Save".
  4. File the message in one of my client folders.
  5. Switch to OmniFocus, select planning mode, and select the destination project.
  6. Select the new task (which was added at the end of the project).
  7. Click the "notes" icon a single "From ..." line appears.
  8. Click in that single line, and the note expands to show the key sentence from the message.
  9. Click the "Original Message" link, and Mail comes to the front, displaying the entire message (with attached images) in a new Window.
  10. Click "Show in Mailbox" in the message window, and Mail expands MAILBOXES > Inbox (in the sidebar) to show all accounts, and selects the account on which the message arrived.
Step 10 has failed showing the Inbox folder instead of the folder where the message actually resides (from step 4).

Although "Show in Maibox" is a Mail feature, it's not clear whether the failure is due to entirely to Mail or whether OmniFocus has a hand in the game with its "Original Message" link.

I hope this problem can be fixed by OmniFocus because I don't have much faith in the Apple Mother Ship paying attention to a "Show in Mailbox" bug report when another application is involved.

-- Ward

[submitted as formal feedback]

Last edited by Ward; 2009-05-25 at 12:36 PM.. Reason: work-around a vBulletin layout bug
 
Hmm, I am unable to reproduce this problem. Following your steps exactly, when I click the "Show in Mailbox" link in Apple Mail it seems to work fine.

Perhaps there is some kind of corruption in Mail's database? I don't know if this will help, but have you tried the Mailbox -> Rebuild command in Mail?

My gut tells me that this has nothing to do specifically with OmniFocus, but I don't really know.

-Dennis
 
Show In Mailbox is horribly broken in Apple Mail. I spent many, many hours trying to sort out how to get Applescripts to show mail messages. It's extremely fragile. I ultimately settled on installing MailTags and have been very happy with the linking that it provides. I'm not sure if the Clip-o-tron is using the MailTags link or not, but the Clip-o-tron links work fine for me.
__________________
Cheers,

Curt
 
Quote:
Originally Posted by curt.clifton View Post
Show In Mailbox is horribly broken in Apple Mail. I spent many, many hours trying to sort out how to get Applescripts to show mail messages. It's extremely fragile.
That's disappointing to hear. I haven't done much with Mail and AppleScript, but from a user perspective, Show In Mailbox has been pretty solid for me. In fact, I don't ever recall it not working. Now that I've said that, I'm sure it'll suddenly stop working for me. ;-)

-Dennis
 
Quote:
Originally Posted by Ward View Post
Although "Show in Maibox" is a Mail feature, it's not clear whether the failure is due to entirely to Mail or whether OmniFocus has a hand in the game with its "Original Message" link.
I'm afraid OmniFocus has no control over this: the only information it records is the URL of the message, which looks like this:

Code:
message:<07113BFD-9471-4F7D-8A1B-DCD373E77429@omnigroup.com>
OmniFocus doesn't know anything about where that message is stored (which mailbox, which email server, or even which email application), it simply tells your Mac to open that URL. From that point, it's up to the system to hand off the URL to Mail (or another email app), and what happens after that is up to that application.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Project "dashboard" with comments? [A: Feature request filed.] shivohum OmniFocus 1 for Mac 1 2013-01-24 12:16 PM
"Next Action OR Flagged" filtering possible? [A: Feature request filed.] markatdvcrc OmniFocus 1 for Mac 5 2012-02-25 07:19 AM
Mail's "Send to OmniFocus" keyboard shortcut broken tjfallis@blackrockmarketi OmniFocus 1 for Mac 7 2012-02-10 11:25 PM
How to show completed actions? [A: use View menu ("Eye button") to show All] Patrick923 OmniFocus for iPad 2 2010-08-06 06:10 AM
SOLVED: Sync always triggers "no longer compatible" message IntlOrange OmniFocus Syncing 6 2008-07-23 10:39 AM


All times are GMT -8. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.