The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Why do I have to click twice on Perspectives? Thread Tools Search this Thread Display Modes
Hi,

I created some custom perspectives to aid me in my workflow but I'm finding that there is some residue with the perspectives I have saved and what shows up.

Right now I am having to click on a perspective toolbar icon shortcut twice in order for it to show properly. For example, if I'm on a screen that has an inbox, and then I click on my perspective "Daily Actions" the inbox follows. However if I click the shortcut again it goes to normal. Is this a feature in play which I'm not aware of?

Much thanks,
David
 
I'm guessing this has to do with the state of the "Restore: Selection" box for that perspective, but I've been unable to generate the two-click behavior you're describing with my own perspectives.

Would it be possible for you to post a picture of the Perspectives window with that one selected in the sidebar?

(You can take a screenshot by pressing command-shift-4, which will give you a selection cursor. Tap your Space key, click on the window you want to capture, and when you release the mouse the image will be saved to your desktop as 'Picture 1', 'Picture 2', etc.)

You can then use the paperclip button in the post editor to attach the screenshot to your post. That'll help us figure out what's going on.
 
Quote:
Originally Posted by Brian View Post
when you release the mouse the image will be saved to your desktop as 'Picture 1', 'Picture 2', etc.
With newer systems, it will be the more useful 'Screen shot <date> at <time>' so don't get too upset if you can't find 'Picture 1' :-)
 
Here you are!
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-03-13 at 4.48.46 PM.png
Views:	230
Size:	92.6 KB
ID:	2321  
 
Yeah, I can reproduce that behavior, too. I haven't figured out how to do it with an out-of-the-box database, though.
 
David,

I'm intrigued by some of your perspectives. Are your Inbox: <foo> perspectives a subset of the Inbox, the Inbox + other structures, or other structures? Are you doing a two-level Inbox scheme of some sort?
 
That perspective looks pretty similar to one of my perspectives. (Project-mode, focused on a subset of my projects, same filter settings.)

I'm still not seeing the behavior in that perspective or in a new test one I set up. Maybe it has to do with what was selected/focused when you set up the perspective? Here are the steps I used:
  1. Select several projects in the Project-mode sidebar; do not select the Inbox.
  2. Select View -> Focus on <selected projects> from the menu bar.
  3. Select Perspective -> Save window as -> New Perspective from the menu bar.

Maybe my perspective-creation steps are different in a way that causes me to not tickle the bug?
 
Nope, I can do that exact set of steps and trigger it.

I select two projects from the top of the sidebar, do View->Focus, Perspectives->Save Window As New Perspective, click on the perspective icon to end the edit of the perspective name (imaginatively called "Perspective 8" in this case), then put it in the toolbar by control-clicking in the toolbar and dragging in the icon. Bring up the All Items perspective (which shows the Inbox), then bring up the new perspective and the first time, I'll usually get the Inbox in the display. I'll even get the Inbox on occasion when the previous view doesn't include it, such as if I ping-pong between two similar versions of this perspective (showing different projects, but otherwise the same in construction and form). Clicking on the button again always seems to fix it. Attached images show result after first invocation, second invocation, and the perspective details.
Attached Thumbnails
Click image for larger version

Name:	Screen shot 2012-03-13 at 5.54.27 PM.png
Views:	200
Size:	10.4 KB
ID:	2322   Click image for larger version

Name:	Screen shot 2012-03-13 at 5.54.51 PM.png
Views:	183
Size:	8.0 KB
ID:	2323   Click image for larger version

Name:	Screen shot 2012-03-13 at 5.55.08 PM.png
Views:	186
Size:	45.8 KB
ID:	2324  
 
Grrr... SOFTWARE! ;-)

Followed the steps in your post, Bill, didn't get it to happen, then repeated the steps and got it to happen but couldn't figure out why. Have now repeated the steps several more times and no dice.

I got the inbox to show up one time, but every time since, clicking the "Perspective 8" (or what have you) icon in the toolbar leaves me with those two projects selected in the sidebar and no inbox visible.
 
I've submitted a bug report which includes an abbreviated database displaying the problem. I'd give you a bug number, except the auto-responder hasn't bothered to respond in the 10+ minutes since I sent it!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Double-click for Focus in New Window gone? [A: v1.9 changed to Option-Double Click.] bjornkri OmniFocus 1 for Mac 11 2012-05-17 09:52 AM
one click / right click email NorCalPaul OmniFocus Extras 2 2010-09-22 01:16 PM
right click menu ghostdog75 OmniWeb Feature Requests 1 2007-05-25 06:11 PM
Right Click Mephux OmniWeb General 1 2006-07-26 12:24 PM
Right Click -> Go Back escrafford OmniWeb Feature Requests 3 2006-07-02 11:33 AM


All times are GMT -8. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.