The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
OmniWeb and The Spinning Beachball of Death Thread Tools Search this Thread Display Modes
I use OW as my primary browser, and have done that for a year or so. It's perhaps my favourite app for the Mac, so I am kinda patient with the program.

But... It seems that every fifth minute, the program freezes, and the beachball appears. The only thing I can do is forcing OW to quit, and then restart it, which really is a pain in the a*se. It has happened now and again in the past, but this is getting redicilous.

For the record, I have a MacBook with the latest Tiger build, and I maintain the system with Onyx so that everything should be running smoothly.

Any tips?
 
Wait for 5.6.
 
Known issue with JS and garbage collection in the version of WebKit that OmniWeb is currently based on. When the update to a more recent version of WebKit is complete (which is due to occur in 5.6, hence Forrest's short response) this shouldn't happen anymore.
 
Well, this could be a JavaScript issue. It could be something else though, I would suggest the original poster to contact support (via Send Feedback in the help menu). We can take a closer look at the problem, we actually don't get a huge number of reports regarding the javascript issue.

Before writing into support you may want to get a sample of OmniWeb during the freeze. The sample will help tell us what exactly OmniWeb is trying to do at this time.

To do this, open the Activity Monitor--an app found in your Applications, Utilities folder. Select OmniWeb from the list, double click on it. In the new window click on "Sample", this will open up one more window--after it completes save the content to a text file. Include this when you write into us and we'll get back to you as soon as possible.
 
Quote:
Originally Posted by troyb
Well, this could be a JavaScript issue. It could be something else though<snip>
True - my bad.
Quote:
we actually don't get a huge number of reports regarding the javascript issue.
Well, I could start sending you them again if you really want, but I think I'll get a little bored of doing it every half hour/hour or so that I'm using OmniWeb ;)
 
Oh i wasn't trying to imply that this problem no longer exists. I'm just saying that there is a sect of people that are hitting it and in my experience that sect isn't the majority.

We know that both you and Forrest and many other users are still experiencing the problem, sorry about that.
 
Hey troy, what else have you guys found that causes this? I'd like to know just because then I can keep an eye out and see if I'm running into those issues too.
 
Well I'm pretty sure you're just seeing the javascript issue, I don't recall ever seeing samples from you that looked like it could be something else causing the problem.

I could see Bookmark checking / syncing causing some performance problems. Very large AutoFill databases can as well. The main performance problem area at the moment is your JavaScript one though. I just don't want to jump to conclusions and assume that's what's causing problems for people and have them wait for 5.6 under the assumption that it's going to be fixed only to find that it's not. Especially if it's something we can help with now.
 
All this time, I have been blaming the well-known JavaScript issues for all my trouble with OmniWeb. It didn't crash all that frequently, but the memory leaks were pretty bad, and it beachballed *all* the time.

When I updated the OS to 10.4.9 recently, I backed up/formatted/re-installed. I was having sort of very general trouble with the system, and wanted a fresh start. Since then (about a week ago, now), OmniWeb has not beachballed once. I've still got the WebKit memory leaks, of course, but there's nothing about OW's behaviour that's debilitating in the least. I've gotten into the habit of not loading more than 20 or so tabs and of flushing the cache and quitting/relaunching every once in a while, but earlier, I was getting continuous SBBs *in spite* of these checks and balances. I no longer do, which makes me think I was wrong about the cause, after all.

I don't have any hard data (logs, screenshots, etc.) that could help you, so this is sort of just a general fyi.

I can't even express how thrilled I am to be reminded why I purchased an OmniWeb license in the first place.
 
Thank you for your kind replies gentlemen, I will do as suggested.

:D
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spinning beachball on startup xsive OmniGraffle General 0 2011-10-24 07:35 PM
Ouch! spinning rainbow of death benatan OmniFocus 1 for Mac 4 2007-12-14 10:45 AM
Spinning beachball starting with VPN connection! autophile OmniOutliner 3 for Mac 1 2007-10-08 02:28 PM
Spinning beachball - ?overload 65hefalumps OmniOutliner 3 for Mac 2 2007-04-05 07:34 AM
SBBOD (spinning beach ball of death) on certain sites adamwebb OmniWeb Bug Reports 2 2007-01-18 09:24 AM


All times are GMT -8. The time now is 07:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.