The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus for iPhone
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Sync issues on iPhone 3GS hardware [SOLVED] Thread Tools Search this Thread Display Modes
Some folks with Apple's latest iPhone hardware appear to be having trouble getting sync to work on their new phones.

The problem seems to affect all the different forms of sync, and seems to be specific to the new hardware. It appears to affect new customers as well as folks migrating forward from the previous versions of the phone.

We got access to the new phone hardware at the same time as everyone else, so we're looking into the problem but thus far haven't been able to reproduce the problem on our hardware.

We're very sorry for the inconvenience this is causing, and would like to ask that folks experiencing this to please contact our support ninjas so we can gather information about the problem and either fix it or communicate it to Apple, as appropriate.

Some of the customers having this problem have reported that sync will suddenly just start working; they try over and over and over, and then it suddenly starts working with no change in OmniFocus' settings seemingly being responsible. Until we have more information, trying to initiate a sync on the phone a couple of times a day is our best recommendation.

Again, we're very sorry for the inconvenience this is causing.
I have a 3GS and had syncing issues with webdav. After typing in my settings the spinner keeps going but it looks hung. Then I did a bunch of things at once, and I'm not sure what helped. I created a local database, turned on both experimental features (landscape mode and undo support) and tried syncing again. That made it work.
Just tried this and it didn't work for me. In some of my attempts in the past, the 3GS has seen the desktop OF, but the desktop doesn't find or recognize the iPhone. This time, neither saw the other one.

Ideas anyone?
I had some difficulty at first getting my database to sync to my new iPhone 3GS via MobileMe. It turned out that OmniFocus on my iPhone was stalling because it apparently failed to authenticate with my MobileMe account and didn't prompt me for a password.

I worked around it by switching OmniFocus for iPhone to using Bonjour, then switched back to MobileMe and manually configured it from the iPhone. I then got the MobileMe password prompt in OmniFocus and proceeded successfully.

I'm not sure if I could reproduce the issue again; I wasn't paying very close attention along the way, so I might even be missing a step. But I thought I'd post my experience here anyway. Maybe it'll help someone else.

(Sorry I didn't notice this thread earlier; this is a repeat of what I posted on Friday over in the OmniFocus syncing forum)

OK, it turns out the problem isn't related to the 3GS, it's simply a bug with setting up syncing for the first time in OmniFocus 1.5 on iPhone OS 3.0. It doesn't happen all the time, but I was able to reproduce it in one out of three tries on my iPod touch.

The good news is that now that we've figured out how to reproduce the problem (at least once in a while), we've come up with a workaround (which we've also added to our FAQ):

I'm having trouble setting up Synchronization in OmniFocus for iPhone 1.5 under iPhone OS 3.0. Can you help?

There's currently a bug in OmniFocus for iPhone that may prevent you from successfully entering your credentials when syncing. To get around it when setting up synchronization:

On the first launch screen, choose "Make New Database" (counter-intuitive, right?)
Go to settings and set up sync as normal.
Go back to the home screen, and if sync is spinning without prompting for a username and password, quit OmniFocus.
Relaunch OmniFocus, press sync and you should be prompted for a username/password.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sync issues related to replacing database w/Time Machin [Solved: set up prefs again] leo Bonjour sync 2 2010-12-09 05:03 PM
Unable to sync w/Bonjour since iPhone Omnifocus update [SOLVED: Blocked by router.] Nutty87th OmniFocus Syncing 7 2010-04-29 01:44 AM
Can't get OmniFocus to sync with iPhone [SOLVED] jim0203 Bonjour sync 17 2010-04-28 11:07 AM
Why closing OF so slow? Performance issues ? [SOLVED: Sync accidentally enabled] amg OmniFocus 1 for Mac 12 2009-05-11 05:06 PM
SOLVED: iPhone OmniFocus refuses to sync with WebDAV, authentication issue lazerfire OmniFocus for iPhone 0 2008-08-02 04:14 PM

All times are GMT -8. The time now is 02:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.