The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Mail script: Send to OF unreliable Thread Tools Search this Thread Display Modes
I regularly send emails to me+omnifocus. It works whenever I have the computer running but seems to fail when I am out and the computer is asleep. When the computer wakes the script does not complete. I'm using the following Mail rule:

1) If Any Recipient Contains +omnifocus
2) Mark as Read
3) Mark as Flagged
4) Run AppleScript .....MailAction.applescript
5) Stop evaluating Rules

As I remember from the past, the scrip would run as soon as OF for Mac is opened or when the computer wakes (OF having remained running during sleep). Now only the first three steps above are actioned, up to setting the flag, but the AppleScript to send to OF is not executing. If I do a test message while in front of the computer the script executes correctly.

Anyone have any bright ideas?
Do you have an iPhone or iPod touch that you also use to read your email? It has been my experience that if I send an email to my +omnifocus address at from my iPod, it will not be handed off to OmniFocus because the Mail app on my Mac won't be the first entity to handle that message, even if I don't actually read the message. If I send to a different account than the one I'm actively using, the problem does not occur.
The problem does occur when I send from my iPhone. I am sending from to and, of course, the Mail app on the iPhone downloads the message, although I leave it unread. This could be the reason and I can experiment with sending from to a different address. The strange thing is that the Rule is working on the home Mac but it stops short of running the OF script.
Further... I have tried sending from one mail account to the other but get the same result. The problem seems to be connected with sending from the iPhone, irrespective of which address I use. My @me account is set up on the iPhone as default, so I particularly wish to use this for sending. My other main service, @gmx, rejects the me+omnifocus address as invalid, so I'm back to sending from @me to @me. It ought to work...
Well, one easy workaround is to get yourself a gmail account simply for OmniFocus' use -- gmail accepts the +omnifocus notation without complaint.
Thanks for your continued interest. I do have a gmail account but forgot. I've set it up and the messages are accepted. However, I get the same result: the message comes into the @me box, is flagged and marked as read but the message is not added to OF.

I have also stripped out the Rule so that only the AppleScript is listed. It works perfectly when I send from the Mac but doesn't work when I send from the iPhone (from gmail to @me). Strange, but it must be something to do with the iPhone sending and I wonder if anyone else has had this problem.
You misunderstood my suggestion, I think -- you send *to* the gmail account, and don't read that account with your iPod/iPhone.
Originally Posted by whpalmer4 View Post
You misunderstood my suggestion, I think -- you send *to* the gmail account, and don't read that account with your iPod/iPhone.
I have actually done exactly what whpalmer4 suggests here: Create a mail account that you set up only in Apple Mail and nowhere else (don't even read it in a browser!!). It sounds awkward perhaps, but it's done in literary a minute and requires no maintenance at all as long as you don't give that address to anyone. (Gmail account set up as imap in Mail)
This has been a constant problem for me too.

I have tried a MobileMe mail account, i.e., I have tried a Gmail IMAP account, e.g., (very unreliable results.) As well as a Gmail POP account (same poor results.)

I wonder if it is related to PowerPC versions of OmniFocus. I've spent time troubleshooting with the Ninjas, I'll get it working, and then, BOOM, it will start to fail again without warning or any change in configuration.

It's maddening because the GTD method requires a "trusted receptacle" but when I send an email from iPhone to OF, many times it's like I sent it straight to the garbage.

Sometimes it's the fault of the sending mail client not attaching a proper plain-text version of the email for the script to process. Are you using the regular iPhone mail client, or are you using a web mail client or some other alternative? If you are, try plain-old-mail.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Send task as e-mail Arild OmniFocus Extras 1 2010-03-09 02:44 AM
Send email to OmniOutliner Script cjlemonier OmniOutliner 3 for Mac 0 2009-09-15 09:53 AM
Send Mail message (with link) to OF Inbox zooids OmniFocus 1 for Mac 19 2007-11-20 05:49 PM
Adding Tasks Via Send To OmniFocus Mail Rule, Mailtags, & Mail Act-On reuben OmniFocus 1 for Mac 0 2007-11-18 06:07 PM

All times are GMT -8. The time now is 11:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.