The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Omnifocus will not quit Thread Tools Search this Thread Display Modes
I run my MBP at work on the corporate network, at home on my private network over VPN. There are always a few hiccups going between the two, and Omnifocus sync seemed to be a hangup if I tried to quit the application after I'd switched network modes, so I've been making a point to quit before I leave one location and then start it up again when I reach the other.

Lately, though, Omnifocus will not shut down cleanly. I get the spinning ball of death for a while, then it goes unresponsive, and then I kill it. I try to make sure that my sync is done before I quit, so I'm not sure what it's doing on the way out that is hanging it up.

I just killed it, brought it back up, let the autosync finish, then clicked once for a manual sync, waited for the wheel to stop turning, then hit Quit. Here it sits in limbo land again.

Anyone else seen behavior like this? I sync with WebDav, and my iPhone ad Mac both seem happy enough with that. Not sure makes quitting fail.

Maybe I need to write to the support Ninja's and send the problem report information.
It goes to Not Responding when I try to archive old data and reduce the database size, too. Rats.
How long are you waiting? Just because the status goes to Not Responding doesn't mean that it would recover. It could be that OF is trying to compress your database on exit and isn't getting enough time to finish. (I've seen similar problems with other apps, and with OF a few versions ago. Typically, once the app is given enough time to finish its clean up, it runs fine after that.)

I'd suggest contacting the Support Ninjas (Help → Send Feedback). They can walk you through the steps to "sample" the application, which will give the developers enough information to fix the problem in future releases.

Are you mounting any network disk volumes, such as the MobileMe iDisk? If you are, and leave the network where you did before dismounting them, OmniFocus (and other apps) will probably hang when they next attempt to open files on any of your disks. After a minute or two, if all goes well, you'll get a popup window alerting you that the server has disconnected you and the machine will be usable again. Try unmounting any network volumes before leaving the network and see if that doesn't avoid the hangs. It doesn't sound to me like this is necessarily an OF issue, just that OF happens to be the app first attempting to access the disk.
I just ran another "quit test" having arrived in the office today. While I've been futzing around with other things it did eventually manage to close itself.

The notion is that I can shut down Omnifocus before I leave the office, it will sync up with WebDav, and then I'll use the iPhone while I'm mobile.

The new model seems to be I can shut down Omnifocus long before I'm planning to leave the office.

It's funny, if I load it up on my little white Macbook (running on the company's open wireless) it quits almost immediately, so maybe it has something to do with the way it interacts inside our secure network.

I don't mind if it takes a long time to shut down, as long as it tells me what it's doing. For instance, it will tell me if it's doing a WebDav sync and give me the option to cancel if that's what it's up to, but if it's compressing databases or other housekeeping chores it is not telling me... it just spins the marble and becomes unresponsive.

I'll try the support ninjas and see what they have to say.

Last edited by Vramin; 2009-07-23 at 10:10 AM.. Reason: fixed a typo
I've been having issues for awhile where Omnifocus just takes forever to close when I'm trying to shutdown.

Compressing the database on this thread helped (I also turned syncing off first - for some reason it was set on with no settings, but that didn't seem to help - but I figure it can't hurt to have it set to nothing).

Sounds like you're sorted, but just in case you're curious....

Having sync enabled but with no sync server specified may actually have been the root of your problem. When syncing, compression happens as part of the process. If you're not syncing anywhere, the app needs to do it periodically. If the app thinks you're syncing when you're actually not, compression might never happen.

It may not have appeared to do anything right away, to disable syncing, but it probably scheduled a compression to happen soon.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Impossible to quit Omnifocus mschwarz OmniFocus 1 for Mac 7 2009-01-21 07:10 AM
Tried to quit but got this BevvyB OmniFocus 1 for Mac 4 2008-08-23 05:42 AM
Only backing up on quit? msc OmniFocus 1 for Mac 1 2008-01-30 09:14 AM
OmniWeb 554 won't quit ahl032 OmniWeb General 7 2007-07-04 08:35 PM
Omniweb will not quit c53204 OmniWeb Bug Reports 3 2007-04-02 10:55 AM

All times are GMT -8. The time now is 02:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.