The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

OmniFocus does not start anymore Thread Tools Search this Thread Display Modes
I don't know what changed but OmniFocus cannot be started anymore on my mac.

When I click on it the icon starts to jump as usual. The icon even displays the number of my tasks then it suddenly quits.

I have tried the following:

1.) Deleted the app, and downloaded a new one from the net, and reinstalled it.
2.) Removed the folder containing my tasks: /Users/username/Library/Application Support/OmniFocus
3.) Removed "OmniFocus Backups" folder from my Documents folder.

Still no luck.

All I have is the following lines in the log:

2011-08-27 2:11:31.250 PM [0x0-0x154154].com.omnigroup.OmniFocus: forwarding exception, port = 0x0, behaviour = 0, flavor = 0
2011-08-27 2:11:31.250 PM [0x0-0x154154].com.omnigroup.OmniFocus: forward_exception got unknown behavior
2011-08-27 2:11:31.250 PM [0x0-0x154154].com.omnigroup.OmniFocus: thread_set_state (os/kern) invalid argument
2011-08-27 2:11:31.254 PM ([0x0-0x154154].com.omnigroup.OmniFocus[14710]) Exited with code: 1

I am running on Mac Os X 10.7.1

Any suggestions?
You should probably contact support directly on this one; you'll get a faster response.
I have found the solution accidentally. I had problems with httpd also. As it turned out one library was missing. Apache did write its problem into the event log:

org.apache.httpd[21227]: dyld: Library not loaded: /usr/lib/libpq.5.dylib
org.apache.httpd[21227]: Referenced from: /usr/sbin/httpd
org.apache.httpd[21227]: Reason: image not found[1] (org.apache.httpd[21227]): Job appears to have crashed: Trace/BPT trap: 5[1] (org.apache.httpd): Throttling respawn: Will start in 10 seconds
ReportCrash[21216]: Saved crash report for httpd[21227] version ??? (???) to /Library/Logs/DiagnosticReports/httpd_2011-08-28-003002_localhost.crash

A closer look confirmed that '/usr/lib/libpq.5.dylib' does not exist but I had '/usr/lib/libpq.5.3.dylib'. Making a symbolic link solved my problem:

sudo ln -s /usr/lib/libpq.5.3.dylib /usr/lib/libpq.5.dylib

This also made OmniFocus work again!

The cause is probably postgresql 9.0.4 installer (dmg), I am not sure though.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
won't sync anymore juliang OmniFocus for iPhone 3 2009-07-08 10:22 AM
Omnifocus for iPhone canīt find me anymore Nicolas_Thomsen OmniFocus for iPhone 1 2009-02-03 01:11 AM
With Omnifocus/iPhone do I need iCal sync anymore? Dan OmniFocus for iPhone 21 2009-01-21 06:18 PM

All times are GMT -8. The time now is 01:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.